summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 02:10:43 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 02:10:43 +0000
commitc33a981eec4e52697c81cd453b1101e2b20910cb (patch)
tree5aa58f9b77e86a0aeda544cb46fa990d244f6371 /dev-libs/gmp/gmp-4.1.2.ebuild
parentDEBUGBUILD -> use debug (diff)
downloadgentoo-2-c33a981eec4e52697c81cd453b1101e2b20910cb.tar.gz
gentoo-2-c33a981eec4e52697c81cd453b1101e2b20910cb.tar.bz2
gentoo-2-c33a981eec4e52697c81cd453b1101e2b20910cb.zip
DEBUG -> use debug
Diffstat (limited to 'dev-libs/gmp/gmp-4.1.2.ebuild')
-rw-r--r--dev-libs/gmp/gmp-4.1.2.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-libs/gmp/gmp-4.1.2.ebuild b/dev-libs/gmp/gmp-4.1.2.ebuild
index b7c718c56dd4..ccf11acbc652 100644
--- a/dev-libs/gmp/gmp-4.1.2.ebuild
+++ b/dev-libs/gmp/gmp-4.1.2.ebuild
@@ -1,22 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.2.ebuild,v 1.5 2003/03/15 14:48:09 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.2.ebuild,v 1.6 2003/08/03 02:10:33 vapier Exp $
-inherit flag-o-matic
-inherit libtool
+inherit flag-o-matic libtool
+filter-flags -ffast-math
DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
SRC_URI="mirror://gnu/gmp/${P}.tar.gz"
-KEYWORDS="~x86 ~ppc ~sparc alpha"
-SLOT="0"
LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc alpha"
DEPEND="~sys-devel/m4-1.4"
-filter-flags -ffast-math
-
src_compile() {
elibtoolize
@@ -27,14 +25,14 @@ src_compile() {
--localstatedir=/var/state/gmp \
--enable-cxx \
--enable-mpbsd \
- ${myconf} || die "configure failed"
-
+ ${myconf} \
+ || die "configure failed"
emake || die "emake failed"
# It's pretty slow to run all the checks, and not really necessary
# on every build of this package. Just run the checks when
# debugging is enabled. (23 Feb 2003 agriffis)
- if [ -n "$DEBUG" ]; then
+ if [ `use debug` ] ; then
make check || die "make check failed"
fi
}