summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2013-01-26 00:22:14 +0000
committerJory Pratt <anarchy@gentoo.org>2013-01-26 00:22:14 +0000
commit78f4e21270af6d797889a7790d13a507eadafdfc (patch)
treec8c8ab73bd657fddff22d3692095a76465c94780 /dev-libs/jemalloc
parentfixed typo (diff)
downloadgentoo-2-78f4e21270af6d797889a7790d13a507eadafdfc.tar.gz
gentoo-2-78f4e21270af6d797889a7790d13a507eadafdfc.tar.bz2
gentoo-2-78f4e21270af6d797889a7790d13a507eadafdfc.zip
Misc upstream bug fixes, refer to changelog
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xB4D088B4)
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/ChangeLog9
-rw-r--r--dev-libs/jemalloc/jemalloc-3.3.0.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-libs/jemalloc/ChangeLog b/dev-libs/jemalloc/ChangeLog
index 7e448b4803ee..79ec2b9e91c5 100644
--- a/dev-libs/jemalloc/ChangeLog
+++ b/dev-libs/jemalloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/jemalloc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.25 2012/12/29 19:28:18 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.26 2013/01/26 00:22:14 anarchy Exp $
+
+*jemalloc-3.3.0 (26 Jan 2013)
+
+ 26 Jan 2013; <anarchy@gentoo.org> +jemalloc-3.3.0.ebuild:
+ Misc upstream bug fixes, refer to changelog
29 Dec 2012; Raúl Porcel <armin76@gentoo.org> jemalloc-3.2.0.ebuild:
Add ~alpha wrt #429708
diff --git a/dev-libs/jemalloc/jemalloc-3.3.0.ebuild b/dev-libs/jemalloc/jemalloc-3.3.0.ebuild
new file mode 100644
index 000000000000..cbe0fa88284c
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-3.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-3.3.0.ebuild,v 1.1 2013/01/26 00:22:14 anarchy Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+IUSE="debug static-libs stats"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-3.0.0-strip-optimization.patch" \
+ "${FILESDIR}/${PN}-3.0.0-no-pprof.patch" \
+ "${FILESDIR}/${PN}-3.0.0_fix_html_install.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable stats)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+ dodoc ChangeLog README
+ dohtml doc/jemalloc.html
+
+ use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +
+}