summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2003-02-08 16:27:11 +0000
committerJ Robert Ray <jrray@gentoo.org>2003-02-08 16:27:11 +0000
commitf2eaae13efd85fc0d699386051d12b280d3aa0c8 (patch)
treec4e25e950c8c4a78c16ec606639454e0a0a7af8f /dev-libs/libgcrypt/libgcrypt-1.1.12.ebuild
parentNew version (unstable ppc) (diff)
downloadgentoo-2-f2eaae13efd85fc0d699386051d12b280d3aa0c8.tar.gz
gentoo-2-f2eaae13efd85fc0d699386051d12b280d3aa0c8.tar.bz2
gentoo-2-f2eaae13efd85fc0d699386051d12b280d3aa0c8.zip
version bump
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.1.12.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.1.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.1.12.ebuild b/dev-libs/libgcrypt/libgcrypt-1.1.12.ebuild
new file mode 100644
index 000000000000..1fb550e4c519
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.1.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.1.12.ebuild,v 1.1 2003/02/08 16:27:11 jrray Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libgcrypt is a general purpose crypto library based on the code used in GnuPG."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnupg.org"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="app-text/jadetex
+ app-text/docbook-sgml-utils
+ >=app-text/docbook-dsssl-stylesheets-1.77-r2"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+IUSE="nls"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/scripts
+
+ mv db2any db2any.orig
+ sed -e 's:docbook-to-man:docbook2man:g' \
+ -e 's:\^usage:^Usage:' \
+ -e 's:^/usr/share/dsssl/stylesheets/docbook:/usr/share/sgml/stylesheets/dsssl/docbook:' \
+ db2any.orig > db2any
+ chmod +x db2any
+}
+
+src_compile() {
+ econf $(use_enable nls) --disable-dependency-tracking || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING* NEWS README* THANKS TODO VERSION
+}