summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:02:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:02:39 +0000
commit10a102ec8ff3f11500cdf945f68631d3f3490719 (patch)
tree428654f340215726d1e105ddf6db044b4aa4eecc /dev-libs/libsigc++
parentJaxp was a repack of various apache projects under a very restrictive Sun lic... (diff)
downloadgentoo-2-10a102ec8ff3f11500cdf945f68631d3f3490719.tar.gz
gentoo-2-10a102ec8ff3f11500cdf945f68631d3f3490719.tar.bz2
gentoo-2-10a102ec8ff3f11500cdf945f68631d3f3490719.zip
repoman'd
Diffstat (limited to 'dev-libs/libsigc++')
-rw-r--r--dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild12
-rw-r--r--dev-libs/libsigc++/libsigc++-1.1.11.ebuild16
2 files changed, 12 insertions, 16 deletions
diff --git a/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild b/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
index 3e0cab05d683..04da81945a14 100644
--- a/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild,v 1.2 2002/07/11 06:30:21 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild,v 1.3 2002/08/01 18:02:37 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The GLib library of C routines"
SRC_URI="http://download.sourceforge.net/libsigc/${P}.tar.gz"
HOMEPAGE="http://libsigc.sourceforge.net/"
+
SLOT="1.0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="x86"
DEPEND="virtual/glibc"
@@ -21,11 +24,7 @@ src_compile() {
myconf="--enable-debug=no"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die
+ econf ${myconf} || die
# Fix sandbox violation when old libsig++ is already installed,
# hopefully this will go away after the header location settles down
@@ -61,4 +60,3 @@ pkg_postinst() {
einfo ""
einfo "**********************************************************"
}
-
diff --git a/dev-libs/libsigc++/libsigc++-1.1.11.ebuild b/dev-libs/libsigc++/libsigc++-1.1.11.ebuild
index 33b5be62f605..73664878575f 100644
--- a/dev-libs/libsigc++/libsigc++-1.1.11.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.1.11.ebuild,v 1.3 2002/08/01 11:59:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.1.11.ebuild,v 1.4 2002/08/01 18:02:37 seemant Exp $
# unstable branch should have debugging.
@@ -11,7 +11,11 @@ S=${WORKDIR}/${P}
DESCRIPTION="The GLib library of C routines"
SRC_URI="http://download.sourceforge.net/libsigc/${P}.tar.gz"
HOMEPAGE="http://libsigc.sourceforge.net/"
+
SLOT="1.2"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
src_compile() {
@@ -25,11 +29,7 @@ src_compile() {
myconf="--enable-debug=no"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die
+ econf ${myconf} || die
# Fix sandbox violation when old libsig++ is already installed,
# hopefully this will go away after the header location settles down
@@ -49,9 +49,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} \
- install || die
-
+ make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
}