summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-11-26 20:44:36 +0000
committerDan Armak <danarmak@gentoo.org>2002-11-26 20:44:36 +0000
commit69f4bf26d06ab0e0d98dc3b96d6142435eb7b857 (patch)
treec8719500b18eb8c88cb4df5d5a8639b4fd2f1f9d /dev-libs/libxml2/libxml2-2.4.28.ebuild
parentmask new libxml2-2.4.28 (diff)
downloadgentoo-2-69f4bf26d06ab0e0d98dc3b96d6142435eb7b857.tar.gz
gentoo-2-69f4bf26d06ab0e0d98dc3b96d6142435eb7b857.tar.bz2
gentoo-2-69f4bf26d06ab0e0d98dc3b96d6142435eb7b857.zip
new libxml2-2.4.28 with a pathc that fixes the kde doc generation bug
Diffstat (limited to 'dev-libs/libxml2/libxml2-2.4.28.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-2.4.28.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libxml2/libxml2-2.4.28.ebuild b/dev-libs/libxml2/libxml2-2.4.28.ebuild
new file mode 100644
index 000000000000..8a14312ddc88
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.4.28.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.28.ebuild,v 1.1 2002/11/26 20:44:36 danarmak Exp $
+
+inherit libtool gnome2
+
+IUSE="zlib python readline"
+S=${WORKDIR}/${P}
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="zlib? ( sys-libs/zlib )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="~x86 ~sparc ~sparc64 ~ppc ~alpha"
+
+src_unpack() {
+
+ unpack $A
+ cd $S
+ patch -p0 < $FILESDIR/parser.c.diff || die
+
+}
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf
+
+ use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}