summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-31 23:10:10 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-31 23:10:10 +0000
commit633f1d34a1cc27807be2c71517ad8a2314a8c3b3 (patch)
treee5f1606e11e2f76f1daa19c6a213d24d6e4d541c /dev-libs/libxslt
parentamd64 stable, bug #271444 (diff)
downloadgentoo-2-633f1d34a1cc27807be2c71517ad8a2314a8c3b3.tar.gz
gentoo-2-633f1d34a1cc27807be2c71517ad8a2314a8c3b3.tar.bz2
gentoo-2-633f1d34a1cc27807be2c71517ad8a2314a8c3b3.zip
Remove unused configure flags, bug #230750. Move documentation to one folder.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog7
-rw-r--r--dev-libs/libxslt/libxslt-1.1.24-r1.ebuild27
2 files changed, 19 insertions, 15 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index c2bf2c93e25a..ea857af6ff36 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxslt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.189 2009/05/31 18:37:29 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.190 2009/05/31 23:10:10 eva Exp $
+
+ 31 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ libxslt-1.1.24-r1.ebuild:
+ Remove unused configure flags, bug #230750. Move documentation to one
+ folder.
31 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
-files/libxslt-1.1.20-amd64.patch, -libxslt-1.1.22.ebuild:
diff --git a/dev-libs/libxslt/libxslt-1.1.24-r1.ebuild b/dev-libs/libxslt/libxslt-1.1.24-r1.ebuild
index 4b7401b96cf6..441faa1917db 100644
--- a/dev-libs/libxslt/libxslt-1.1.24-r1.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.24-r1.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.24-r1.ebuild,v 1.2 2008/11/05 00:36:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.24-r1.ebuild,v 1.3 2009/05/31 23:10:10 eva Exp $
inherit libtool eutils python autotools
DESCRIPTION="XSLT libraries and tools"
HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
IUSE="crypt debug examples python"
-DEPEND=">=dev-libs/libxml2-2.6.27
+RDEPEND=">=dev-libs/libxml2-2.6.27
crypt? ( >=dev-libs/libgcrypt-1.1.92 )
python? ( dev-lang/python )"
-
-SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
@@ -46,25 +46,24 @@ src_unpack() {
}
src_compile() {
- # Always pass --with-debugger. It is required by third parties (see
- # e.g. bug #98345)
- local myconf="--with-debugger \
- $(use_with python) \
+ local myconf="$(use_with python) \
$(use_with crypt crypto) \
$(use_with debug) \
$(use_with debug mem-debug)"
- econf ${myconf} || die "configure failed"
-
+ econf ${myconf}
emake || die "Compilation failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
+ emake DESTDIR="${D}" \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ install || die "Installation failed"
- dodoc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
+ dodoc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO || die "dodoc failed"
+ rm -rf "${D}/usr/share/doc/${PN}-python-${PV}"
if ! use examples; then
- rm -rf "${D}/usr/share/doc/${PN}-python-${PV}/examples"
+ rm -rf "${D}/usr/share/doc/${PF}/python/examples"
fi
}