summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-11 20:44:50 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-11 20:44:50 +0000
commit9f4d1449f7a09d502d90442e3b8aa85b17f73f60 (patch)
tree9737ff2001cbe523f137e13ecf18e055a98b49e1 /dev-libs/tre/tre-0.7.2.ebuild
parent~amd64 bug #70206 (Manifest recommit) (diff)
downloadgentoo-2-9f4d1449f7a09d502d90442e3b8aa85b17f73f60.tar.gz
gentoo-2-9f4d1449f7a09d502d90442e3b8aa85b17f73f60.tar.bz2
gentoo-2-9f4d1449f7a09d502d90442e3b8aa85b17f73f60.zip
Version bump as per bug #76796
Diffstat (limited to 'dev-libs/tre/tre-0.7.2.ebuild')
-rw-r--r--dev-libs/tre/tre-0.7.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/tre/tre-0.7.2.ebuild b/dev-libs/tre/tre-0.7.2.ebuild
new file mode 100644
index 000000000000..abd5ddf10239
--- /dev/null
+++ b/dev-libs/tre/tre-0.7.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tre/tre-0.7.2.ebuild,v 1.1 2005/01/11 20:44:50 dragonheart Exp $
+
+IUSE="nls static"
+
+DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library."
+HOMEPAGE="http://laurikari.net/tre/index.html"
+SRC_URI="http://laurikari.net/tre/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/sed
+ sys-devel/gettext
+ sys-devel/libtool
+ sys-devel/gcc
+ dev-util/pkgconfig"
+
+RDEPEND="virtual/libc
+ !app-misc/glimpse
+ !app-text/agrep"
+
+src_compile() {
+ # Build TRE library.
+ cd ${S}
+ econf \
+ `use_enable nls` \
+ `use_enable static` \
+ --enable-agrep \
+ --enable-system-abi \
+ --disable-profile \
+ --disable-debug || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ cd ${S}
+ dohtml doc/tre-api.html doc/tre-syntax.html
+}
+
+
+pkg_postinst() {
+ ewarn "Both app-misc/glimpse, app-text/agrep and this package provide agrep."
+ ewarn "they seem to be similar but just to let you know."
+ ewarn "If this causes a problem please do a bug report"
+ ewarn "bugs.gentoo.org."
+}