summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-02-19 10:13:10 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-02-19 10:13:10 +0000
commit483e129b4f7a06bff53a120acd751b524e2130e9 (patch)
treece57bb40b8f27b189ab48d395af33f7d04066f09 /dev-libs/zthread
parentStable for hppa, wrt bug #458122 (diff)
downloadgentoo-2-483e129b4f7a06bff53a120acd751b524e2130e9.tar.gz
gentoo-2-483e129b4f7a06bff53a120acd751b524e2130e9.tar.bz2
gentoo-2-483e129b4f7a06bff53a120acd751b524e2130e9.zip
Fix bug #269988, use default's and prune_libtool_files, update the automake patch to not add LDFLAGS to LIBADD.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'dev-libs/zthread')
-rw-r--r--dev-libs/zthread/ChangeLog11
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch75
-rw-r--r--dev-libs/zthread/zthread-2.3.2-r3.ebuild64
3 files changed, 148 insertions, 2 deletions
diff --git a/dev-libs/zthread/ChangeLog b/dev-libs/zthread/ChangeLog
index f6a49626c1e5..ea80e2bc67bf 100644
--- a/dev-libs/zthread/ChangeLog
+++ b/dev-libs/zthread/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/zthread
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/ChangeLog,v 1.32 2012/06/23 11:48:56 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/ChangeLog,v 1.33 2013/02/19 10:13:10 dev-zero Exp $
+
+*zthread-2.3.2-r3 (19 Feb 2013)
+
+ 19 Feb 2013; Tiziano Müller <dev-zero@gentoo.org>
+ +files/zthread-2.3.2-automake-r2.patch, +zthread-2.3.2-r3.ebuild:
+ Fix bug #269988, use default's and prune_libtool_files, update the automake
+ patch to not add LDFLAGS to LIBADD.
23 Jun 2012; Kacper Kowalik <xarthisius.kk@gmail.com>
+files/zthread-2.3.2-gcc47.patch, zthread-2.3.2-r2.ebuild:
diff --git a/dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch b/dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch
new file mode 100644
index 000000000000..bcd9e0675979
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch
@@ -0,0 +1,75 @@
+From 577b34b74b7a73650d906f371044bfaed6e8b74c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tiziano=20M=C3=BCller?= <tm@dev-zero.ch>
+Date: Tue, 19 Feb 2013 10:13:12 +0100
+Subject: [PATCH] Use standard automake rules rather than hand coding the
+ install rules and append linker flags to LDFLAGS and not LDADD, otherwise
+ --as-needed gets ignored (and possibly others).
+
+---
+ Makefile.am | 21 +++++----------------
+ configure.ac | 1 -
+ src/Makefile.am | 2 --
+ 3 files changed, 5 insertions(+), 19 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 6c092cf..2d7bddf 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -24,24 +24,13 @@ LICENSE \
+ MIT.TXT \
+ depcomp
+
++bin_SCRIPTS = share/zthread-config
+
+-## install the config script
+-install-exec-hook:
+- $(mkinstalldirs) $(bindir)
+- $(INSTALL_PROGRAM) $(top_srcdir)/share/zthread-config $(bindir)
++aclocaldir = $(datadir)/aclocal
++aclocal_DATA = share/zthread.m4 share/pthread.m4
+
+-## install the config script & m4 macros
+-install-data-hook:
+- $(mkinstalldirs) $(datadir)/aclocal
+- $(INSTALL_DATA) $(top_srcdir)/share/zthread.m4 $(datadir)/aclocal
+- $(INSTALL_DATA) $(top_srcdir)/share/pthread.m4 $(datadir)/aclocal
+- mkdir -p $(DESTDIR)$(includedir)/zthread
+- cp -pR $(top_srcdir)/include/zthread $(DESTDIR)$(includedir)/
+-
+-## uninstall the config script & m4 macros
+-uninstall-local:
+- -rm -rf $(datadir)/aclocal/pthread.m4
+- -rm -rf $(datadir)/aclocal/zthread.m4
++zincludedir = $(includedir)/zthread
++zinclude_HEADERS = include/zthread/*.h
+
+ distclean-local:
+ -rm -rf $(top_srcdir)/$(PACKAGE)-$(VERSION).tar.gz
+diff --git a/configure.ac b/configure.ac
+index 866041b..5d32a58 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -226,7 +226,6 @@ AC_TRY_LINK( [#include <windows.h>], [_beginthreadex((void*)0, 0, 0, (void*)0, 0
+
+ dnl Configure the final compiler & linker options
+ COMPILER_OPTIONS="$COMPILER_OPTIONS $CXXFLAGS"
+-LINKER_OPTIONS="$LINKER_OPTIONS $LDFLAGS"
+
+ dnl Configured flags for compiling ZThreads
+ AC_SUBST(LINKER_OPTIONS)
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 04404d6..35dc764 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -21,8 +21,6 @@ AM_CXXFLAGS = @COMPILER_OPTIONS@ @EXTRA_COMPILER_OPTIONS@
+ INCLUDES = -I$(top_srcdir)/include
+ SUBDIRS=.
+
+-libdir=$(prefix)/lib
+-
+ lib_LTLIBRARIES = libZThread.la
+
+ libZThread_la_LIBADD=@LINKER_OPTIONS@ @EXTRA_LINKER_OPTIONS@
+--
+1.8.1.1
+
diff --git a/dev-libs/zthread/zthread-2.3.2-r3.ebuild b/dev-libs/zthread/zthread-2.3.2-r3.ebuild
new file mode 100644
index 000000000000..6b53ac642ced
--- /dev/null
+++ b/dev-libs/zthread/zthread-2.3.2-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/zthread-2.3.2-r3.ebuild,v 1.1 2013/02/19 10:13:10 dev-zero Exp $
+
+EAPI="5"
+
+inherit eutils autotools
+
+MY_P="ZThread-${PV}"
+
+DESCRIPTION="platform-independent multi-threading and synchronization library for C++"
+HOMEPAGE="http://zthread.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zthread/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="debug doc kernel_linux static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ rm -f include/zthread/{.Barrier.h.swp,Barrier.h.orig} || die
+ epatch \
+ "${FILESDIR}"/${P}-no-fpermissive.diff \
+ "${FILESDIR}"/${P}-m4-quote.patch \
+ "${FILESDIR}"/${P}-automake-r2.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ AT_M4DIR="share" eautoreconf
+}
+
+src_configure() {
+ local myconf
+ # Autoconf does not support --disable-debug properly.
+ use debug && myconf="--enable-debug"
+
+ econf \
+ $(use_enable kernel_linux atomic-linux) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen doc/zthread.doxygen || die
+ sed -i -e 's|href="html/|href="|' doc/documentation.html || die
+ cp doc/documentation.html doc/html/index.html || die
+ cp doc/{zthread.css,bugs.js} doc/html/ || die
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dohtml doc/html/*
+
+ prune_libtool_files
+}