summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-12-31 20:00:21 +0000
committerAron Griffis <agriffis@gentoo.org>2002-12-31 20:00:21 +0000
commit0e98bccf9a9c417ce307fd774cb560eb84a859cd (patch)
tree2dec37b02fab6d8e9b7f9ffdace5f09e4acd66b0 /dev-libs
parentsee changelog (diff)
downloadgentoo-2-0e98bccf9a9c417ce307fd774cb560eb84a859cd.tar.gz
gentoo-2-0e98bccf9a9c417ce307fd774cb560eb84a859cd.tar.bz2
gentoo-2-0e98bccf9a9c417ce307fd774cb560eb84a859cd.zip
Add ev6 support with ~alpha
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libcpml/ChangeLog8
-rw-r--r--dev-libs/libcpml/files/digest-libcpml-5.2.01-r10
-rw-r--r--dev-libs/libcpml/libcpml-5.2.01-r1.ebuild49
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-libs/libcpml/ChangeLog b/dev-libs/libcpml/ChangeLog
index dbaaf5a25773..75ec3ee09c7e 100644
--- a/dev-libs/libcpml/ChangeLog
+++ b/dev-libs/libcpml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libcpml
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcpml/ChangeLog,v 1.2 2002/12/17 19:18:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcpml/ChangeLog,v 1.3 2002/12/31 20:00:21 agriffis Exp $
+
+*libcpml-5.2.01-r1 (31 Dec 2002)
+
+ 31 Dec 2002; Aron Griffis <agriffis@gentoo.org> libcpml-5.2.01-r1.ebuild:
+ Use ev6 flag to determine which math library to use. KEYWORDS=~alpha for
+ the moment until it's known safe.
*libcpml-5.2.01 (15 Dec 2002)
15 Dec 2002; Bjoern Brauel <bjb@gentoo.org>
diff --git a/dev-libs/libcpml/files/digest-libcpml-5.2.01-r1 b/dev-libs/libcpml/files/digest-libcpml-5.2.01-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-libs/libcpml/files/digest-libcpml-5.2.01-r1
diff --git a/dev-libs/libcpml/libcpml-5.2.01-r1.ebuild b/dev-libs/libcpml/libcpml-5.2.01-r1.ebuild
new file mode 100644
index 000000000000..c831039f519a
--- /dev/null
+++ b/dev-libs/libcpml/libcpml-5.2.01-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcpml/libcpml-5.2.01-r1.ebuild,v 1.1 2002/12/31 20:00:21 agriffis Exp $
+
+S=${WORKDIR}/usr
+SRC_URI=""
+DESCRIPTION="Compaq Linux optimized math library for Alpha/Linux/GNU"
+HOMEPAGE="http://h18000.www1.hp.com/math/index.html"
+DEPEND="virtual/glibc
+ app-arch/rpm2targz "
+RDEPEND="$DEPEND"
+LICENSE="compaq-sdla"
+SLOT="5.2.01"
+KEYWORDS="-x86 -ppc -sparc ~alpha"
+IUSE="ev6"
+
+src_unpack() {
+ local EV; use ev6 && EV=ev6 || EV=ev5
+ At="cpml_${EV}-5.2.0-1.alpha.rpm"
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE}"
+ fi
+ rpm2targz ${DISTDIR}/${At}
+ tar zxf cpml_ev5-5.2.0-1.alpha.tar.gz
+ mv usr/doc/cpml-5.2.0/* usr
+}
+
+src_compile () {
+ local EV; use ev6 && EV=ev6 || EV=ev5
+ cd ${WORKDIR}/usr/lib/compaq/cpml-5.2.0
+ ld -shared -o libcpml_${EV}.so -soname libcpml.so -whole-archive libcpml_${EV}.a -no-whole-archive -lots
+}
+
+src_install () {
+ local EV; use ev6 && EV=ev6 || EV=ev5
+
+ dodir /usr/lib
+ cp -a lib/compaq/cpml-5.2.0/libcpml* ${D}/usr/lib
+
+ dodir /usr/include
+ cp lib/compaq/cpml-5.2.0/cpml.h ${D}/usr/include
+
+ dodoc README Release_Notes-5.2.0
+
+ cd ${D}/usr/lib/
+ ln -s libcpml_${EV}.so libcpml.so
+ ln -s libcpml_${EV}.a libcpml.a
+}
+