summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-11-21 08:58:37 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-11-21 08:58:37 +0000
commit39f52d2d8f6d8044e34b97b3d638a630bf0ef58c (patch)
treef8e495e000c8314049f3aac78edbbb014edefae9 /dev-libs
parentmark stable on x86 since it is the initial ebuild (diff)
downloadgentoo-2-39f52d2d8f6d8044e34b97b3d638a630bf0ef58c.tar.gz
gentoo-2-39f52d2d8f6d8044e34b97b3d638a630bf0ef58c.tar.bz2
gentoo-2-39f52d2d8f6d8044e34b97b3d638a630bf0ef58c.zip
fixed test cases for 1.0.11 and 1.0.12. Patch courtesy of Olaf Freyer <aaron@cs.tu-berlin.de> in bug #70529.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/log4c/ChangeLog8
-rw-r--r--dev-libs/log4c/files/log4c-1.0.11-function.patch19
-rw-r--r--dev-libs/log4c/files/log4c-1.0.12-function.patch19
-rw-r--r--dev-libs/log4c/log4c-1.0.11.ebuild5
-rw-r--r--dev-libs/log4c/log4c-1.0.12.ebuild18
5 files changed, 58 insertions, 11 deletions
diff --git a/dev-libs/log4c/ChangeLog b/dev-libs/log4c/ChangeLog
index adf22fbedde0..7e7746652107 100644
--- a/dev-libs/log4c/ChangeLog
+++ b/dev-libs/log4c/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/log4c
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.19 2004/11/20 01:02:23 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.20 2004/11/21 08:58:37 dragonheart Exp $
+
+ 21 Nov 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/log4c-1.0.11-function.patch, +files/log4c-1.0.12-function.patch,
+ log4c-1.0.11.ebuild, log4c-1.0.12.ebuild:
+ fixed test cases for 1.0.11 and 1.0.12. Patch courtesy of Olaf Freyer
+ <aaron@cs.tu-berlin.de> in bug #70529.
*log4c-1.0.10-r1 (20 Nov 2004)
diff --git a/dev-libs/log4c/files/log4c-1.0.11-function.patch b/dev-libs/log4c/files/log4c-1.0.11-function.patch
new file mode 100644
index 000000000000..576ee21acce3
--- /dev/null
+++ b/dev-libs/log4c/files/log4c-1.0.11-function.patch
@@ -0,0 +1,19 @@
+--- src/sd/error.h.orig 2004-11-21 08:29:18.168483856 +0930
++++ src/sd/error.h 2004-11-21 08:32:48.421520536 +0930
+@@ -14,13 +14,13 @@
+ #ifdef __SD_DEBUG__
+
+ # define __sd_str(n) #n
+-# define __sd_location(n) __FUNCTION__"() at " __FILE__":" __sd_str(n)
++# define __sd_location(n) "() at " __FILE__":" __sd_str(n)
+ # define sd_location __sd_location(__LINE__)
+
+ # define sd_debug(a_format, ...) \
+- (getenv("SD_DEBUG") ? fprintf(stderr, "[DEBUG] "sd_location" "a_format"\n", ##__VA_ARGS__ ) : 0)
++ (getenv("SD_DEBUG") ? fprintf(stderr, "[DEBUG] %s"sd_location" "a_format"\n", __FUNCTION__,##__VA_ARGS__ ) : 0)
+ # define sd_error(a_format, ...) \
+- (getenv("SD_ERROR") ? fprintf(stderr, "[ERROR] "sd_location" "a_format"\n", ##__VA_ARGS__ ) : 0)
++ (getenv("SD_ERROR") ? fprintf(stderr, "[ERROR] %s"sd_location" "a_format"\n", __FUNCTION__,##__VA_ARGS__ ) : 0)
+ # define sd_oserror(afunc, aparam) \
+ (sd_error("%s(%s): #%d %s", afunc, aparam, errno, strerror(errno)), -1)
+
diff --git a/dev-libs/log4c/files/log4c-1.0.12-function.patch b/dev-libs/log4c/files/log4c-1.0.12-function.patch
new file mode 100644
index 000000000000..576ee21acce3
--- /dev/null
+++ b/dev-libs/log4c/files/log4c-1.0.12-function.patch
@@ -0,0 +1,19 @@
+--- src/sd/error.h.orig 2004-11-21 08:29:18.168483856 +0930
++++ src/sd/error.h 2004-11-21 08:32:48.421520536 +0930
+@@ -14,13 +14,13 @@
+ #ifdef __SD_DEBUG__
+
+ # define __sd_str(n) #n
+-# define __sd_location(n) __FUNCTION__"() at " __FILE__":" __sd_str(n)
++# define __sd_location(n) "() at " __FILE__":" __sd_str(n)
+ # define sd_location __sd_location(__LINE__)
+
+ # define sd_debug(a_format, ...) \
+- (getenv("SD_DEBUG") ? fprintf(stderr, "[DEBUG] "sd_location" "a_format"\n", ##__VA_ARGS__ ) : 0)
++ (getenv("SD_DEBUG") ? fprintf(stderr, "[DEBUG] %s"sd_location" "a_format"\n", __FUNCTION__,##__VA_ARGS__ ) : 0)
+ # define sd_error(a_format, ...) \
+- (getenv("SD_ERROR") ? fprintf(stderr, "[ERROR] "sd_location" "a_format"\n", ##__VA_ARGS__ ) : 0)
++ (getenv("SD_ERROR") ? fprintf(stderr, "[ERROR] %s"sd_location" "a_format"\n", __FUNCTION__,##__VA_ARGS__ ) : 0)
+ # define sd_oserror(afunc, aparam) \
+ (sd_error("%s(%s): #%d %s", afunc, aparam, errno, strerror(errno)), -1)
+
diff --git a/dev-libs/log4c/log4c-1.0.11.ebuild b/dev-libs/log4c/log4c-1.0.11.ebuild
index 77c2fc3476fb..5ce3be1875fa 100644
--- a/dev-libs/log4c/log4c-1.0.11.ebuild
+++ b/dev-libs/log4c/log4c-1.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.11.ebuild,v 1.5 2004/10/09 16:52:58 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.11.ebuild,v 1.6 2004/11/21 08:58:37 dragonheart Exp $
inherit eutils
@@ -26,6 +26,7 @@ src_unpack() {
epatch ${FILESDIR}/makefile.doc.in.patch || die "failed to patch"
epatch ${FILESDIR}/configure.in.patch || die "failed to patch"
epatch ${FILESDIR}/log4c_1.0.11_test.patch || die "failed to patch"
+ epatch ${FILESDIR}/${P}-function.patch || die "failed to patch"
}
src_compile() {
@@ -44,7 +45,7 @@ src_compile() {
}
src_test() {
- einfo "Cannot get test working. patches welcome on bugs.gentoo.org"
+ ${S}/tests/log4c/test_category || die "test_rc failed"
}
src_install() {
diff --git a/dev-libs/log4c/log4c-1.0.12.ebuild b/dev-libs/log4c/log4c-1.0.12.ebuild
index 7c36c625ddee..510f5dd9c6de 100644
--- a/dev-libs/log4c/log4c-1.0.12.ebuild
+++ b/dev-libs/log4c/log4c-1.0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.12.ebuild,v 1.2 2004/10/28 12:34:42 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.12.ebuild,v 1.3 2004/11/21 08:58:37 dragonheart Exp $
inherit eutils
@@ -18,13 +18,13 @@ DEPEND="doc? ( >=app-doc/doxygen-1.2.15
virtual/ghostscript )
>=media-gfx/graphviz-1.7.15-r2"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-function.patch
+}
- #local myconf
- #if has maketest ${FEATURES} || use maketest;
- #then
- # myconf="${myconf} --enable-test"
- #fi
+src_compile() {
econf --enable-test `use_enable doc` || die
use doc && addwrite "${ROOT}/var/cache/fonts"
@@ -32,7 +32,9 @@ src_compile() {
}
src_test() {
- einfo "Cannot get test working. patches welcome on bugs.gentoo.org"
+ # test case broken
+ #${S}/tests/log4c/test_rc || die "test_rc failed"
+ ${S}/tests/log4c/test_category || die "test_rc failed"
}
src_install() {