summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-19 09:26:09 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-19 09:26:09 +0000
commit74a691404e263d8660e0fc04d32e6dff2b5d12b1 (patch)
treed8ce1bf4ef8983db1d9d98a302f91eed05408a6d /dev-libs
parentadded Japanese support. (diff)
downloadgentoo-2-74a691404e263d8660e0fc04d32e6dff2b5d12b1.tar.gz
gentoo-2-74a691404e263d8660e0fc04d32e6dff2b5d12b1.tar.bz2
gentoo-2-74a691404e263d8660e0fc04d32e6dff2b5d12b1.zip
Security update
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog12
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.6i-r11
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.7a-r11
-rw-r--r--dev-libs/openssl/openssl-0.9.6i-r1.ebuild85
-rw-r--r--dev-libs/openssl/openssl-0.9.7a-r1.ebuild78
5 files changed, 176 insertions, 1 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index ad64f1c30290..36d5077e1bad 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-libs/openssl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.31 2003/03/13 22:27:16 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.32 2003/03/19 09:26:09 aliz Exp $
+
+*openssl-0.9.6i-r1 (19 Mar 2003)
+
+ 19 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
+
+*openssl-0.9.7a-r1 (19 Mar 2003)
+
+ 19 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
13 Mar 2003; Guy Martin <gmsoft@gento.org> openssl-0.9.6i.ebuild :
Now produce also libssl.so on hppa.
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.6i-r1 b/dev-libs/openssl/files/digest-openssl-0.9.6i-r1
new file mode 100644
index 000000000000..145478a9699f
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.6i-r1
@@ -0,0 +1 @@
+MD5 9c4db437c17e0b6412c5e4645b6fcf5c openssl-0.9.6i.tar.gz 2179559
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.7a-r1 b/dev-libs/openssl/files/digest-openssl-0.9.7a-r1
new file mode 100644
index 000000000000..60ac183e3e6d
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.7a-r1
@@ -0,0 +1 @@
+MD5 a0d3203ecf10989fdc61c784ae82e531 openssl-0.9.7a.tar.gz 2776582
diff --git a/dev-libs/openssl/openssl-0.9.6i-r1.ebuild b/dev-libs/openssl/openssl-0.9.6i-r1.ebuild
new file mode 100644
index 000000000000..15400cdac39a
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.6i-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6i-r1.ebuild,v 1.1 2003/03/19 09:26:09 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="http://www.openssl.org/source/${P}.tar.gz"
+HOMEPAGE="http://www.openssl.org/"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=dev-lang/perl-5"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~mips ~hppa ~arm"
+IUSE=""
+
+if [ "$PROFILE_ARCH" = "sparc" -a "`uname -m`" = "sparc64" ]; then
+ SSH_TARGET="linux-sparcv8"
+fi
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-blinding.patch
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ if [ "${ARCH}" = "mips" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/openssl-0.9.6-mips.diff
+ fi
+
+ if [ "${ARCH}" = "arm" ]; then
+ # patch linker to add -ldl or things linking aginst libcrypto fail
+ sed -e \
+ 's!^"linux-elf-arm"\(.*\)::BN\(.*\)!"linux-elf-arm"\1:-ldl:BN\2!' \
+ Configure > Configure.orig
+ elif [ "${ARCH}" = "hppa" ]; then
+ sed -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure > Configure.orig
+ else
+ cp Configure Configure.orig
+ fi
+ sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure.orig > Configure
+}
+
+src_compile() {
+ if [ ${SSH_TARGET} ]; then
+ einfo "Forcing ${SSH_TARGET} compile"
+ ./Configure ${SSH_TARGET} --prefix=/usr \
+ --openssldir=/etc/ssl shared threads || die
+ else
+ ./config --prefix=/usr --openssldir=/etc/ssl shared threads || die
+ fi
+ # i think parallel make has problems
+ make all || die
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} MANDIR=/usr/share/man install || die
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+
+ # The man pages rand.3 and passwd.1 conflict with other packages
+ # Rename them to ssl-* and also make a symlink from openssl-* to ssl-*
+ cd ${D}/usr/share/man/man1
+ mv passwd.1 ssl-passwd.1
+ ln -sf ssl-passwd.1 openssl-passwd.1
+ cd ${D}/usr/share/man/man3
+ mv rand.3 ssl-rand.3
+ ln -sf ssl-rand.3 openssl-rand.3
+
+ # create the certs directory. Previous openssl builds
+ # would need to create /usr/lib/ssl/certs but this looks
+ # to be the more FHS compliant setup... -raker
+ dodir /etc/ssl/certs
+
+}
+
diff --git a/dev-libs/openssl/openssl-0.9.7a-r1.ebuild b/dev-libs/openssl/openssl-0.9.7a-r1.ebuild
new file mode 100644
index 000000000000..8038278802c3
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.7a-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7a-r1.ebuild,v 1.1 2003/03/19 09:26:09 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="http://www.openssl.org/source/${P}.tar.gz"
+HOMEPAGE="http://www.openssl.org/"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=dev-lang/perl-5"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa"
+
+warning() {
+ ewarn "BIG FAT WARNING!!!"
+ ewarn "You must re-emerge every package that links to openssl after you have merged ${P}"
+ ewarn "This is becuse packages that links against ${PN} links against the full version"
+ ewarn "Also, if you don't have the sources for the packages you need to re-emerge you"
+ ewarn "should download them with emerge -f prior to the installation of ${P}."
+ ewarn "This is becuse wget may be linked against ${PN}."
+ ewarn "To generate a list of packages that links against ${PN} you can download"
+ ewarn "and run the script from http://cvs.gentoo.org/~aliz/openssl_update.sh"
+ ewarn "If you are using binary packages you need to rebuild those against the"
+ ewarn "new version of ${PN}"
+ sleep 10
+}
+
+src_unpack() {
+ warning
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-blinding.patch
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ if [ "${ARCH}" = "hppa" ]; then
+ sed -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure > Configure.orig
+ else
+ cp Configure Configure.orig
+ fi
+ sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure.orig > Configure
+}
+
+src_compile() {
+ ./config --prefix=/usr --openssldir=/etc/ssl shared threads || die
+ # i think parallel make has problems
+ make all || die
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} MANDIR=/usr/share/man install || die
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+
+ # The man pages rand.3 and passwd.1 conflict with other packages
+ # Rename them to ssl-* and also make a symlink from openssl-* to ssl-*
+ cd ${D}/usr/share/man/man1
+ mv passwd.1 ssl-passwd.1
+ ln -sf ssl-passwd.1 openssl-passwd.1
+ cd ${D}/usr/share/man/man3
+ mv rand.3 ssl-rand.3
+ ln -sf ssl-rand.3 openssl-rand.3
+
+ # create the certs directory. Previous openssl builds
+ # would need to create /usr/lib/ssl/certs but this looks
+ # to be the more FHS compliant setup... -raker
+ dodir /etc/ssl/certs
+
+}
+