summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-01-27 20:18:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-01-27 20:18:12 +0000
commit1e371c222e26f73f1a517a43f1edd9f7e11f1ea8 (patch)
treeaa664052c4b0136af382c17c4f67dc07914159cf /dev-lisp/cl-acl-compat/cl-acl-compat-1.2.33.20031205.ebuild
parent fixing SRC_URI. closes 39313 (diff)
downloadgentoo-2-1e371c222e26f73f1a517a43f1edd9f7e11f1ea8.tar.gz
gentoo-2-1e371c222e26f73f1a517a43f1edd9f7e11f1ea8.tar.bz2
gentoo-2-1e371c222e26f73f1a517a43f1edd9f7e11f1ea8.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-acl-compat/cl-acl-compat-1.2.33.20031205.ebuild')
-rw-r--r--dev-lisp/cl-acl-compat/cl-acl-compat-1.2.33.20031205.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.33.20031205.ebuild b/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.33.20031205.ebuild
new file mode 100644
index 000000000000..ed907a2909cd
--- /dev/null
+++ b/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.33.20031205.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.33.20031205.ebuild,v 1.1 2004/01/27 20:18:12 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=1.2.33
+CVS_PV=2003.12.05
+
+DESCRIPTION="Compatibility layer for Allegro Common Lisp"
+HOMEPAGE="http://packages.debian.org/unstable/web/cl-acl-compat.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}+cvs${CVS_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cmucl-source
+ virtual/commonlisp"
+
+CLPACKAGE=acl-compat
+
+S=${WORKDIR}/cl-portable-aserve-${MY_PV}+cvs${CVS_PV}
+
+src_install() {
+ dodir /usr/share/common-lisp/source/
+ cp -r acl-compat/ ${D}/usr/share/common-lisp/source/
+ common-lisp-install ${FILESDIR}/acl-compat.asd
+ common-lisp-system-symlink
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}