summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-03 22:08:40 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-03 22:08:40 +0000
commit534e46102f01cee8fdb5ee2e1b8b465023516b68 (patch)
tree6492ddb00657d47aceeaba0ae8ffe231437dd493 /dev-lisp/cl-plus
parentVersion bump. (diff)
downloadgentoo-2-534e46102f01cee8fdb5ee2e1b8b465023516b68.tar.gz
gentoo-2-534e46102f01cee8fdb5ee2e1b8b465023516b68.tar.bz2
gentoo-2-534e46102f01cee8fdb5ee2e1b8b465023516b68.zip
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lisp/cl-plus')
-rw-r--r--dev-lisp/cl-plus/ChangeLog10
-rw-r--r--dev-lisp/cl-plus/Manifest3
-rw-r--r--dev-lisp/cl-plus/cl-plus-1.0.ebuild33
-rw-r--r--dev-lisp/cl-plus/files/digest-cl-plus-1.02
-rw-r--r--dev-lisp/cl-plus/metadata.xml10
5 files changed, 58 insertions, 0 deletions
diff --git a/dev-lisp/cl-plus/ChangeLog b/dev-lisp/cl-plus/ChangeLog
new file mode 100644
index 000000000000..44920b308c96
--- /dev/null
+++ b/dev-lisp/cl-plus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-plus
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-plus/ChangeLog,v 1.1 2005/02/03 22:08:40 mkennedy Exp $
+
+*cl-plus-1.0 (03 Feb 2005)
+
+ 03 Feb 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-plus-1.0.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-plus/Manifest b/dev-lisp/cl-plus/Manifest
new file mode 100644
index 000000000000..61fdbe9e498c
--- /dev/null
+++ b/dev-lisp/cl-plus/Manifest
@@ -0,0 +1,3 @@
+MD5 82a9445391b6d5a1fc37437f850bab94 cl-plus-1.0.ebuild 782
+MD5 47d223069719d3b25fcceb28fb750deb metadata.xml 398
+MD5 de8b941079b37d8caf8de6b1f3d7d830 files/digest-cl-plus-1.0 129
diff --git a/dev-lisp/cl-plus/cl-plus-1.0.ebuild b/dev-lisp/cl-plus/cl-plus-1.0.ebuild
new file mode 100644
index 000000000000..033eed0f38b4
--- /dev/null
+++ b/dev-lisp/cl-plus/cl-plus-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-plus/cl-plus-1.0.ebuild,v 1.1 2005/02/03 22:08:40 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DEB_PV=1
+
+DESCRIPTION="Common Lisp extensions such as a DEFCONSTANT wrappers"
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-plus"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/${PN}/${PN}_${PV}-${DEB_PV}.diff.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=cl-plus
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${PV}-${DEB_PV}.diff || die
+}
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ do-debian-credits
+}
diff --git a/dev-lisp/cl-plus/files/digest-cl-plus-1.0 b/dev-lisp/cl-plus/files/digest-cl-plus-1.0
new file mode 100644
index 000000000000..7445f0719258
--- /dev/null
+++ b/dev-lisp/cl-plus/files/digest-cl-plus-1.0
@@ -0,0 +1,2 @@
+MD5 0cb03e824c923d080ffbfdf03782c164 cl-plus_1.0.orig.tar.gz 831
+MD5 b17d5137111ec5130c3c76b3fb07516e cl-plus_1.0-1.diff.gz 2503
diff --git a/dev-lisp/cl-plus/metadata.xml b/dev-lisp/cl-plus/metadata.xml
new file mode 100644
index 000000000000..2175e6385629
--- /dev/null
+++ b/dev-lisp/cl-plus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Core ANSI Common Lisp extensions to assist in compiling cross-platform
+packages. Currently includes CL+:DEFCONST, which only evaluates a constant's
+initial value when the constant name is unbound.
+</longdescription>
+</pkgmetadata>