summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
commitf0499138e7aa5e43bdb88278d6bef3650c46e229 (patch)
treeb29a74bee14985fc7da4a51785f23c0829b3b5d5 /dev-lisp/cl-uffi
parentinitial common lisp import (diff)
downloadgentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.gz
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.bz2
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-uffi')
-rw-r--r--dev-lisp/cl-uffi/ChangeLog8
-rw-r--r--dev-lisp/cl-uffi/Manifest8
-rw-r--r--dev-lisp/cl-uffi/cl-uffi-1.2.15.ebuild45
-rw-r--r--dev-lisp/cl-uffi/files/digest-cl-uffi-1.2.151
-rw-r--r--dev-lisp/cl-uffi/files/uffi-tests.asd37
-rw-r--r--dev-lisp/cl-uffi/files/uffi.asd48
6 files changed, 143 insertions, 4 deletions
diff --git a/dev-lisp/cl-uffi/ChangeLog b/dev-lisp/cl-uffi/ChangeLog
new file mode 100644
index 000000000000..451ae4489dfc
--- /dev/null
+++ b/dev-lisp/cl-uffi/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cl-uffi
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uffi/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+*cl-uffi-1.2.15 (07 Jul 2003)
+
+ 07 Jul 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ initial import
diff --git a/dev-lisp/cl-uffi/Manifest b/dev-lisp/cl-uffi/Manifest
index 7c7896d28130..7f5279bc7648 100644
--- a/dev-lisp/cl-uffi/Manifest
+++ b/dev-lisp/cl-uffi/Manifest
@@ -1,5 +1,5 @@
-MD5 1b631f0222d1ffce4d5b53bc38f70c51 ChangeLog 320
-MD5 12f3768386c6864da8914309b8a325bb cl-uffi-1.2.15.ebuild 549
-MD5 a8d7c955ab8f1e546a4d1123296decbb cl-uffi-1.2.15.ebuild~ 618
-MD5 f5d654d3e532263fbbf57ec7afcdd093 files/digest-cl-base64-3.2 68
+MD5 2a91fdb04677f7b0be0d5b045931681c ChangeLog 319
+MD5 13cf8918d544b7faebeec1af306f441d cl-uffi-1.2.15.ebuild 1447
MD5 dc8b389800029795c6c5fb5573049e89 files/digest-cl-uffi-1.2.15 63
+MD5 175003894efc92fdaed39c27e2d98b8a files/uffi.asd 1953
+MD5 ce1b5bdea8359eac972f36fd409c1d9e files/uffi-tests.asd 1441
diff --git a/dev-lisp/cl-uffi/cl-uffi-1.2.15.ebuild b/dev-lisp/cl-uffi/cl-uffi-1.2.15.ebuild
new file mode 100644
index 000000000000..3d083c1e5908
--- /dev/null
+++ b/dev-lisp/cl-uffi/cl-uffi-1.2.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uffi/cl-uffi-1.2.15.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="UFFI is a package to [portably] interface Common Lisp programs with C-language compatible libraries."
+HOMEPAGE="http://uffi.med-info.com/"
+SRC_URI="http://files.b9.com/uffi/uffi-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/uffi-${PV}
+
+src_install() {
+ dodir /usr/share/common-lisp/systems
+ insinto /usr/share/common-lisp/source/uffi
+ doins src/*.lisp ${FILESDIR}/uffi.asd
+ dosym /usr/share/common-lisp/source/uffi/uffi.asd \
+ /usr/share/common-lisp/systems/uffi.asd
+# insinto /usr/share/common-lisp/source/uffi-tests
+# doins tests/*.lisp ${FILESDIR}/uffi-tests.asd
+# dosym /usr/share/common-lisp/source/uffi-tests/uffi-tests.asd \
+# /usr/share/common-lisp/systems/uffi-tests.asd
+
+ dodoc COPYRIGHT AUTHORS NEWS README TODO ChangeLog doc/uffi.pdf doc/COPYING.GFDL
+ tar xfz doc/html.tar.gz -C ${D}/usr/share/doc/${P}/
+ for i in examples benchmarks ; do
+ insinto /usr/share/doc/${P}/$i
+ doins $i/*
+ done
+}
+
+pkg_postinst() {
+ /usr/sbin/register-common-lisp-source uffi
+# /usr/sbin/register-common-lisp-source uffi-tests
+}
+
+pkg_prerm() {
+ /usr/sbin/unregister-common-lisp-source uffi
+# /usr/sbin/unregister-common-lisp-source uffi-tests
+}
+
diff --git a/dev-lisp/cl-uffi/files/digest-cl-uffi-1.2.15 b/dev-lisp/cl-uffi/files/digest-cl-uffi-1.2.15
new file mode 100644
index 000000000000..a5fd67ca7b3d
--- /dev/null
+++ b/dev-lisp/cl-uffi/files/digest-cl-uffi-1.2.15
@@ -0,0 +1 @@
+MD5 9ed85ec7e42ca558c93765953a760c61 uffi-1.2.15.tar.gz 160278
diff --git a/dev-lisp/cl-uffi/files/uffi-tests.asd b/dev-lisp/cl-uffi/files/uffi-tests.asd
new file mode 100644
index 000000000000..a140021faadf
--- /dev/null
+++ b/dev-lisp/cl-uffi/files/uffi-tests.asd
@@ -0,0 +1,37 @@
+;;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Base: 10 -*-
+;;;; *************************************************************************
+;;;; FILE IDENTIFICATION
+;;;;
+;;;; Name: uffi-tests.asd
+;;;; Purpose: ASDF system definitionf for uffi testing package
+;;;; Author: Kevin M. Rosenberg
+;;;; Date Started: Apr 2003
+;;;;
+;;;; $Id: uffi-tests.asd,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+;;;; *************************************************************************
+
+(defpackage #:uffi-tests-system
+ (:use #:asdf #:cl))
+(in-package #:uffi-tests-system)
+
+(defsystem uffi-tests
+ :depends-on (:uffi)
+ :components
+ ((:file "rt")
+ (:file "package" :depends-on ("rt"))
+ (:file "strtol" :depends-on ("package"))
+ (:file "atoifl" :depends-on ("package"))
+ (:file "getenv" :depends-on ("package"))
+ (:file "gethostname" :depends-on ("package"))
+ (:file "union" :depends-on ("package"))
+ (:file "arrays" :depends-on ("package"))
+ (:file "time" :depends-on ("package"))
+ (:file "foreign-loader" :depends-on ("package"))
+ (:file "compress" :depends-on ("foreign-loader"))
+ (:file "uffi-c-test-lib" :depends-on ("foreign-loader"))
+ ))
+
+(defmethod perform ((o test-op) (c (eql (find-system :uffi-tests))))
+ (or (funcall (intern (symbol-name '#:do-tests)
+ (find-package '#:regression-test)))
+ (error "test-op failed")))
diff --git a/dev-lisp/cl-uffi/files/uffi.asd b/dev-lisp/cl-uffi/files/uffi.asd
new file mode 100644
index 000000000000..34c2ce468f80
--- /dev/null
+++ b/dev-lisp/cl-uffi/files/uffi.asd
@@ -0,0 +1,48 @@
+;;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Base: 10 -*-
+;;;; *************************************************************************
+;;;; FILE IDENTIFICATION
+;;;;
+;;;; Name: uffi.asd
+;;;; Purpose: ASDF system definition file for UFFI package
+;;;; Author: Kevin M. Rosenberg
+;;;; Date Started: Aug 2002
+;;;;
+;;;; $Id: uffi.asd,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+;;;;
+;;;; This file, part of UFFI, is Copyright (c) 2002 by Kevin M. Rosenberg
+;;;;
+;;;; UFFI users are granted the rights to distribute and use this software
+;;;; as governed by the terms of the Lisp Lesser GNU Public License
+;;;; (http://opensource.franz.com/preamble.html), also known as the LLGPL.
+;;;; *************************************************************************
+
+(defpackage #:uffi-system (:use #:asdf #:cl))
+(in-package #:uffi-system)
+
+#+(or allegro lispworks cmu mcl cormanlisp sbcl scl)
+(defsystem uffi
+ :name "uffi"
+ :author "Kevin Rosenberg <kevin@rosenberg.net>"
+ :version "1.2.x"
+ :maintainer "Kevin M. Rosenberg <kmr@debian.org>"
+ :licence "Lessor Lisp General Public License"
+ :description "Universal Foreign Function Library for Common Lisp"
+ :long-description "UFFI provides a universal foreign function interface (FFI) for Common Lisp. UFFI supports CMUCL, Lispworks, and AllegroCL."
+
+ :components
+ ((:file "package")
+ (:file "primitives" :depends-on ("package"))
+ #+mcl (:file "readmacros-mcl" :depends-on ("package"))
+ (:file "strings" :depends-on ("primitives"))
+ (:file "objects" :depends-on ("primitives"))
+ (:file "aggregates" :depends-on ("primitives"))
+ (:file "functions" :depends-on ("primitives"))
+ (:file "libraries" :depends-on ("package"))
+ (:file "os" :depends-on ("package"))))
+
+#+(or allegro lispworks cmu mcl cormanlisp sbcl scl)
+(defmethod perform ((o test-op) (c (eql (find-system :uffi))))
+ (oos 'load-op 'uffi-tests)
+ (oos 'test-op 'uffi-tests))
+
+