summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-04-21 21:30:00 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-04-21 21:30:00 +0000
commit1bad3a1795b193547e99302e31b64e103df41bdc (patch)
treefa527d0a93692ac0f32c186d2011432e597b231e /dev-lisp
parentAdded new revision with cleanup and support for mmx on amd64. (diff)
downloadgentoo-2-1bad3a1795b193547e99302e31b64e103df41bdc.tar.gz
gentoo-2-1bad3a1795b193547e99302e31b64e103df41bdc.tar.bz2
gentoo-2-1bad3a1795b193547e99302e31b64e103df41bdc.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-yahoo/ChangeLog10
-rw-r--r--dev-lisp/cl-yahoo/Manifest3
-rw-r--r--dev-lisp/cl-yahoo/cl-yahoo-0.4.ebuild23
-rw-r--r--dev-lisp/cl-yahoo/files/digest-cl-yahoo-0.41
-rw-r--r--dev-lisp/cl-yahoo/metadata.xml11
5 files changed, 48 insertions, 0 deletions
diff --git a/dev-lisp/cl-yahoo/ChangeLog b/dev-lisp/cl-yahoo/ChangeLog
new file mode 100644
index 000000000000..b629650b2cfa
--- /dev/null
+++ b/dev-lisp/cl-yahoo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-yahoo
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-yahoo/ChangeLog,v 1.1 2005/04/21 21:30:00 mkennedy Exp $
+
+*cl-yahoo-0.4 (21 Apr 2005)
+
+ 21 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-yahoo-0.4.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-yahoo/Manifest b/dev-lisp/cl-yahoo/Manifest
new file mode 100644
index 000000000000..1c407e32c203
--- /dev/null
+++ b/dev-lisp/cl-yahoo/Manifest
@@ -0,0 +1,3 @@
+MD5 05e9855bdb7cc88175652ac49c4c0171 cl-yahoo-0.4.ebuild 599
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 71cc2f875d3ed08175dfcf921adfa6e3 files/digest-cl-yahoo-0.4 62
diff --git a/dev-lisp/cl-yahoo/cl-yahoo-0.4.ebuild b/dev-lisp/cl-yahoo/cl-yahoo-0.4.ebuild
new file mode 100644
index 000000000000..8346f63b6eef
--- /dev/null
+++ b/dev-lisp/cl-yahoo/cl-yahoo-0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-yahoo/cl-yahoo-0.4.ebuild,v 1.1 2005/04/21 21:30:00 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="CL-YAHOO is a Common Lisp interface to the Yahoo! API"
+HOMEPAGE="http://www.cliki.net/cl-yahoo"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~ppc"
+IUSE=""
+DEPEND="dev-lisp/cl-s-xml
+ dev-lisp/cl-trivial-http"
+
+CLPACKAGE=cl-yahoo
+
+src_install() {
+ common-lisp-install cl-yahoo.asd *.lisp
+ common-lisp-system-symlink
+ dodoc README CHANGES COPYING
+}
diff --git a/dev-lisp/cl-yahoo/files/digest-cl-yahoo-0.4 b/dev-lisp/cl-yahoo/files/digest-cl-yahoo-0.4
new file mode 100644
index 000000000000..0b39c245d5bd
--- /dev/null
+++ b/dev-lisp/cl-yahoo/files/digest-cl-yahoo-0.4
@@ -0,0 +1 @@
+MD5 681cc154a1902fb7451f94fe9e85637a cl-yahoo-0.4.tar.gz 9131
diff --git a/dev-lisp/cl-yahoo/metadata.xml b/dev-lisp/cl-yahoo/metadata.xml
new file mode 100644
index 000000000000..16e8a8452099
--- /dev/null
+++ b/dev-lisp/cl-yahoo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+CL-YAHOO is a Common Lisp interface to the Yahoo! API, a networking api which
+enables searching the web through Yahoo Web search, Image search, Spelling, News
+search, Local search (search for businesses in your area), Contextual search,
+and Term extraction are supported.
+</longdescription>
+</pkgmetadata>