summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-19 05:48:36 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-19 05:48:36 +0000
commit6b9cda2e072c9f2727b0c25362f3a8f85a1bb0d9 (patch)
tree4489661f338eaa871b01d61d211929d82c2bc133 /dev-lisp
parentnwe ebuild (diff)
downloadgentoo-2-6b9cda2e072c9f2727b0c25362f3a8f85a1bb0d9.tar.gz
gentoo-2-6b9cda2e072c9f2727b0c25362f3a8f85a1bb0d9.tar.bz2
gentoo-2-6b9cda2e072c9f2727b0c25362f3a8f85a1bb0d9.zip
nwe ebuild
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-uncommonsql/ChangeLog9
-rw-r--r--dev-lisp/cl-uncommonsql/Manifest4
-rw-r--r--dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.0.ebuild35
-rw-r--r--dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.01
4 files changed, 47 insertions, 2 deletions
diff --git a/dev-lisp/cl-uncommonsql/ChangeLog b/dev-lisp/cl-uncommonsql/ChangeLog
new file mode 100644
index 000000000000..e8e98af17291
--- /dev/null
+++ b/dev-lisp/cl-uncommonsql/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lisp/cl-uncommonsql
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uncommonsql/ChangeLog,v 1.1 2003/06/19 05:48:32 mkennedy Exp $
+
+*cl-uncommonsql-1.2.0 (18 Jun 2003)
+
+ 18 Jun 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import.
+
diff --git a/dev-lisp/cl-uncommonsql/Manifest b/dev-lisp/cl-uncommonsql/Manifest
index 6f70ec8ed73c..094f118698ac 100644
--- a/dev-lisp/cl-uncommonsql/Manifest
+++ b/dev-lisp/cl-uncommonsql/Manifest
@@ -1,3 +1,3 @@
-MD5 bf028433084665f288bdf6e5d2102705 ChangeLog 336
-MD5 925d5bce71bd676f966cd1c9dc840b89 cl-uncommonsql-1.2.0.ebuild 1301
+MD5 d8c9a3b44b71d54a9f20c819584d2b0d ChangeLog 343
+MD5 5ea6cf105716f7fab9f4aee72bd703c5 cl-uncommonsql-1.2.0.ebuild 1315
MD5 b1de4fe856dd6fba62cf838680f53de2 files/digest-cl-uncommonsql-1.2.0 77
diff --git a/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.0.ebuild b/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.0.ebuild
new file mode 100644
index 000000000000..cc3c4d8646a8
--- /dev/null
+++ b/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.0.ebuild,v 1.1 2003/06/19 05:48:32 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="UncommonSQL is a database integration kit for Common Lisp. It provides a CommonSQL-compatible interface with a functional SQL syntax and a CLOS integrated Object-to-Relational mapping. You can serialize complete CLOS objects into an RDBMS."
+HOMEPAGE="http://alpha.onshored.com/lisp-software/#uncommonsql"
+SRC_URI="http://alpha.onshored.com/debian/local/${PN}_${PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cl-odcl
+ virtual/commonlisp"
+
+CLPACKAGE=uncommonsql
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/uncommonsql
+ doins *.lisp uncommonsql.system
+ insinto /usr/share/common-lisp/source/uncommonsql/sql
+ doins sql/*.lisp
+ insinto /usr/share/common-lisp/source/uncommonsql/sql/tests
+ doins sql/tests/*.lisp
+
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/uncommonsql/uncommonsql.system \
+ /usr/share/common-lisp/systems/uncommonsql.system
+
+ dodoc CONTRIB* COPYING ChangeLog INSTALL README VERSION TODO
+}
diff --git a/dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.0 b/dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.0
new file mode 100644
index 000000000000..0e98bc1c1b4e
--- /dev/null
+++ b/dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.0
@@ -0,0 +1 @@
+MD5 d68d2f4da016fecc9e8670191d6454f0 cl-uncommonsql_1.2.0.orig.tar.gz 137655