summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 16:58:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 16:58:14 +0000
commitcf6a382b7d38016121d5279facc95a4af1570551 (patch)
tree37429143bae6a2ed9f276841cc99bbf4a768d830 /dev-lisp
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-cf6a382b7d38016121d5279facc95a4af1570551.tar.gz
gentoo-2-cf6a382b7d38016121d5279facc95a4af1570551.tar.bz2
gentoo-2-cf6a382b7d38016121d5279facc95a4af1570551.zip
add inherit eutils
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-asdf/cl-asdf-1.81.ebuild6
-rw-r--r--dev-lisp/cl-awk/cl-awk-1-r1.ebuild15
-rw-r--r--dev-lisp/cl-awk/cl-awk-1.ebuild21
-rw-r--r--dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild11
-rw-r--r--dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild11
-rw-r--r--dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild10
-rw-r--r--dev-lisp/cl-cclan/cl-cclan-1.78.ebuild11
-rw-r--r--dev-lisp/cl-cclan/cl-cclan-1.81-r1.ebuild10
-rw-r--r--dev-lisp/cl-cclan/cl-cclan-1.81.ebuild9
-rw-r--r--dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4-r1.ebuild10
-rw-r--r--dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild10
11 files changed, 65 insertions, 59 deletions
diff --git a/dev-lisp/cl-asdf/cl-asdf-1.81.ebuild b/dev-lisp/cl-asdf/cl-asdf-1.81.ebuild
index f458478aea44..c59efa86afef 100644
--- a/dev-lisp/cl-asdf/cl-asdf-1.81.ebuild
+++ b/dev-lisp/cl-asdf/cl-asdf-1.81.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.81.ebuild,v 1.4 2004/04/15 23:53:47 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.81.ebuild,v 1.5 2004/04/21 16:54:17 vapier Exp $
DEB_PV=1
-inherit common-lisp-common
+inherit common-lisp-common eutils
DESCRIPTION="Another System Definition Facility for Common Lisp"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-asdf.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~sparc ~mips ~ppc s390"
+IUSE=""
src_unpack() {
unpack ${A}
diff --git a/dev-lisp/cl-awk/cl-awk-1-r1.ebuild b/dev-lisp/cl-awk/cl-awk-1-r1.ebuild
index 789db50ab732..147b844cdd2b 100644
--- a/dev-lisp/cl-awk/cl-awk-1-r1.ebuild
+++ b/dev-lisp/cl-awk/cl-awk-1-r1.ebuild
@@ -1,27 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1-r1.ebuild,v 1.1 2004/02/12 09:13:13 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1-r1.ebuild,v 1.2 2004/04/21 16:54:44 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp implementation of AWK"
-HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk
- http://www.cliki.net/RegEx-CLAWK-Lexer
- http://packages.debian.org/unstable/devel/cl-awk.html"
+HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk http://www.cliki.net/RegEx-CLAWK-Lexer http://packages.debian.org/unstable/devel/cl-awk.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_1-${DEB_PV}.diff.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="dev-lisp/cl-regex"
-CLPACKAGE=clawk
+DEPEND="dev-lisp/cl-regex"
S=${WORKDIR}/cl-awk-${PV}
+CLPACKAGE=clawk
+
src_unpack() {
unpack ${A}
epatch cl-awk_${PV}-${DEB_PV}.diff
@@ -31,7 +31,6 @@ src_install() {
common-lisp-install clawk.lisp utils.lisp packages.lisp clawk.asd
common-lisp-system-symlink
do-debian-credits
- dodoc license.txt
docinto examples
dodoc clawktest.lisp emp.data
}
diff --git a/dev-lisp/cl-awk/cl-awk-1.ebuild b/dev-lisp/cl-awk/cl-awk-1.ebuild
index 384041e7109e..a31ddb56f646 100644
--- a/dev-lisp/cl-awk/cl-awk-1.ebuild
+++ b/dev-lisp/cl-awk/cl-awk-1.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1.ebuild,v 1.2 2003/10/15 18:10:05 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1.ebuild,v 1.3 2004/04/21 16:55:19 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp implementation of AWK"
-HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk
- http://www.cliki.net/RegEx-CLAWK-Lexer
- http://packages.debian.org/unstable/devel/cl-awk.html"
+HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk http://www.cliki.net/RegEx-CLAWK-Lexer http://packages.debian.org/unstable/devel/cl-awk.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_1-${DEB_PV}.diff.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="dev-lisp/cl-regex"
-CLPACKAGE=clawk
+DEPEND="dev-lisp/cl-regex"
S=${WORKDIR}/cl-awk-${PV}
+CLPACKAGE=clawk
+
src_unpack() {
unpack ${A}
epatch cl-awk_${PV}-${DEB_PV}.diff
@@ -30,15 +30,14 @@ src_unpack() {
src_install() {
common-lisp-install clawk.lisp utils.lisp packages.lisp clawk.asd
common-lisp-system-symlink
- dodoc license.txt
docinto examples
dodoc clawktest.lisp emp.data
}
pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE} || true
}
pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE} || true
}
diff --git a/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild b/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild
index 4081836d67d7..0bf53498bbdf 100644
--- a/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild
+++ b/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild,v 1.1 2003/10/15 20:47:28 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild,v 1.2 2004/04/21 16:55:37 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Binary-types is a Library for accessing binary files with fixed bit-length code-words. Binary-types provides macros that are used to declare the mapping between Common Lisp objects and some binary (i.e. octet-based) representation."
-HOMEPAGE="http://www.cliki.net/Binary-types
- http://www.cs.uit.no/~frodef/sw/binary-types/"
+HOMEPAGE="http://www.cliki.net/Binary-types http://www.cs.uit.no/~frodef/sw/binary-types/"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-binary-types/cl-binary-types_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-binary-types/cl-binary-types_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
diff --git a/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild b/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild
index 466fec7f37dd..cf00a276b913 100644
--- a/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild
+++ b/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild,v 1.2 2004/02/12 15:42:43 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild,v 1.3 2004/04/21 16:55:52 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
# binary-types moved to http://www.common-lisp.net/project/movitz recently
DESCRIPTION="Binary-types is a Library for accessing binary files with fixed bit-length code-words."
-HOMEPAGE="http://www.cliki.net/Binary-types
- http://www.common-lisp.net/project/movitz/
- http://www.cs.uit.no/~frodef/sw/binary-types/"
+HOMEPAGE="http://www.cliki.net/Binary-types http://www.common-lisp.net/project/movitz/ http://www.cs.uit.no/~frodef/sw/binary-types/"
SRC_URI="http://www.cs.uit.no/~frodef/sw/binary-types/binary-types-0.90.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
diff --git a/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild b/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild
index a5c5eb3fe156..dd5f0a7ac65c 100644
--- a/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild
+++ b/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild
@@ -1,19 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild,v 1.1 2004/02/12 09:13:13 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild,v 1.2 2004/04/21 16:56:12 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=2
DESCRIPTION="Common Lisp implementation of the Blowfish encryption algorithm."
-HOMEPAGE="http://packages.debian.org/unstable/devel/cl-blowfish.html
- http://members.optusnet.com.au/apicard/"
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-blowfish.html http://members.optusnet.com.au/apicard/"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_0.3-2.diff.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
diff --git a/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild b/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild
index 0d61c86c63bb..b31d266757d3 100644
--- a/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild
+++ b/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild,v 1.1 2003/10/15 21:03:58 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild,v 1.2 2004/04/21 16:56:26 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Comprehensive Common Lisp Archive Network"
-HOMEPAGE="http://cclan.sourceforge.net
- http://www.cliki.net/cclan
- http://packages.debian.org/unstable/devel/cl-cclan.html"
+HOMEPAGE="http://cclan.sourceforge.net http://www.cliki.net/cclan http://packages.debian.org/unstable/devel/cl-cclan.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz
http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}.orig.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
diff --git a/dev-lisp/cl-cclan/cl-cclan-1.81-r1.ebuild b/dev-lisp/cl-cclan/cl-cclan-1.81-r1.ebuild
index c3a6f3090a6a..092fa57f212b 100644
--- a/dev-lisp/cl-cclan/cl-cclan-1.81-r1.ebuild
+++ b/dev-lisp/cl-cclan/cl-cclan-1.81-r1.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.81-r1.ebuild,v 1.1 2004/02/12 09:13:13 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.81-r1.ebuild,v 1.2 2004/04/21 16:57:24 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Comprehensive Common Lisp Archive Network"
-HOMEPAGE="http://cclan.sourceforge.net
- http://www.cliki.net/cclan
- http://packages.debian.org/unstable/devel/cl-cclan.html"
+HOMEPAGE="http://cclan.sourceforge.net http://www.cliki.net/cclan http://packages.debian.org/unstable/devel/cl-cclan.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz
http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}.orig.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
DEPEND="dev-lisp/cl-asdf
virtual/commonlisp
diff --git a/dev-lisp/cl-cclan/cl-cclan-1.81.ebuild b/dev-lisp/cl-cclan/cl-cclan-1.81.ebuild
index 9095dd5f5c9d..e8c8a0e31cf6 100644
--- a/dev-lisp/cl-cclan/cl-cclan-1.81.ebuild
+++ b/dev-lisp/cl-cclan/cl-cclan-1.81.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.81.ebuild,v 1.1 2004/01/27 22:10:27 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.81.ebuild,v 1.2 2004/04/21 16:57:38 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Comprehensive Common Lisp Archive Network"
-HOMEPAGE="http://cclan.sourceforge.net
- http://www.cliki.net/cclan
- http://packages.debian.org/unstable/devel/cl-cclan.html"
+HOMEPAGE="http://cclan.sourceforge.net http://www.cliki.net/cclan http://packages.debian.org/unstable/devel/cl-cclan.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz
http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}.orig.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
diff --git a/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4-r1.ebuild b/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4-r1.ebuild
index 4a6dfddc2a56..c0775250dc79 100644
--- a/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4-r1.ebuild
+++ b/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4-r1.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4-r1.ebuild,v 1.1 2004/02/12 09:13:13 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4-r1.ebuild,v 1.2 2004/04/21 16:57:54 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="CLX for SBCL"
-HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/
- http://www.cliki.net/CLX"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/ http://www.cliki.net/CLX"
SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
dev-lisp/sbcl"
diff --git a/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild b/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild
index 345560b5446a..415c4ca64953 100644
--- a/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild
+++ b/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild,v 1.1 2004/02/01 17:53:47 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild,v 1.2 2004/04/21 16:58:14 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="CLX for SBCL"
-HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/
- http://www.cliki.net/CLX"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/ http://www.cliki.net/CLX"
SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
dev-lisp/sbcl"