summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-04-17 00:15:38 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-04-17 00:15:38 +0000
commit2b1165eb03f27ff0e2528fd54a7e5be0688e397c (patch)
tree327565954c5b47073ebb35713490069c0e378091 /dev-lua
parentMask kde-base/gwenview[semantic-desktop], kde-base/okular[dpi] and kde-base/n... (diff)
downloadgentoo-2-2b1165eb03f27ff0e2528fd54a7e5be0688e397c.tar.gz
gentoo-2-2b1165eb03f27ff0e2528fd54a7e5be0688e397c.tar.bz2
gentoo-2-2b1165eb03f27ff0e2528fd54a7e5be0688e397c.zip
Version bump for prosody.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaexpat/ChangeLog7
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-lua/luaexpat/ChangeLog b/dev-lua/luaexpat/ChangeLog
index 75932c417f0f..e683ea489a42 100644
--- a/dev-lua/luaexpat/ChangeLog
+++ b/dev-lua/luaexpat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lua/luaexpat
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaexpat/ChangeLog,v 1.14 2014/03/04 20:37:39 vincent Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaexpat/ChangeLog,v 1.15 2014/04/17 00:15:38 zx2c4 Exp $
+
+*luaexpat-1.3.0 (17 Apr 2014)
+
+ 17 Apr 2014; Jason A. Donenfeld <zx2c4@gentoo.org> +luaexpat-1.3.0.ebuild:
+ Version bump for prosody.
04 Mar 2014; Vicente Olivert Riera <vincent@gentoo.org>
luaexpat-1.2.0-r1.ebuild:
diff --git a/dev-lua/luaexpat/luaexpat-1.3.0.ebuild b/dev-lua/luaexpat/luaexpat-1.3.0.ebuild
new file mode 100644
index 000000000000..7d71f11409a9
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaexpat/luaexpat-1.3.0.ebuild,v 1.1 2014/04/17 00:15:37 zx2c4 Exp $
+
+EAPI=4
+
+inherit multilib toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library."
+HOMEPAGE="http://www.keplerproject.org/luaexpat/"
+SRC_URI="http://matthewwild.co.uk/projects/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1[deprecated]
+ dev-libs/expat"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ append-flags -fPIC
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ LUA_LDIR="$(pkg-config --variable INSTALL_LMOD lua)" \
+ LUA_CDIR="$(pkg-config --variable INSTALL_CMOD lua)" \
+ LUA_INC="-I$(pkg-config --variable INSTALL_INC lua)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LUA_LDIR="$(pkg-config --variable INSTALL_LMOD lua)" \
+ LUA_CDIR="$(pkg-config --variable INSTALL_CMOD lua)" \
+ LUA_INC="-I$(pkg-config --variable INSTALL_INC lua)" \
+ install
+ dodoc README
+ dohtml -r doc/*
+}