summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-20 15:26:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-20 15:26:59 +0000
commitb2af3c04bc9355462f9db51276b3549b1dbc14c5 (patch)
tree6439e9550599096be8f6f7ef82f5c4cbdd0b4930 /dev-ml/ocaml-ssl
parentRemoved ctmkit, ivcall and temperature-app since they have been masked for 60... (diff)
downloadgentoo-2-b2af3c04bc9355462f9db51276b3549b1dbc14c5.tar.gz
gentoo-2-b2af3c04bc9355462f9db51276b3549b1dbc14c5.tar.bz2
gentoo-2-b2af3c04bc9355462f9db51276b3549b1dbc14c5.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocaml-ssl')
-rw-r--r--dev-ml/ocaml-ssl/ChangeLog9
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.4.3.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-ml/ocaml-ssl/ChangeLog b/dev-ml/ocaml-ssl/ChangeLog
index 9067ce463016..9e2840aa16ae 100644
--- a/dev-ml/ocaml-ssl/ChangeLog
+++ b/dev-ml/ocaml-ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-ssl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.12 2008/09/25 12:11:58 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.13 2009/06/20 15:26:59 aballier Exp $
+
+*ocaml-ssl-0.4.3 (20 Jun 2009)
+
+ 20 Jun 2009; Alexis Ballier <aballier@gentoo.org> +ocaml-ssl-0.4.3.ebuild:
+ version bump
25 Sep 2008; Alexis Ballier <aballier@gentoo.org> ocaml-ssl-0.4.2.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.4.3.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.3.ebuild
new file mode 100644
index 000000000000..2603c0c2aeb5
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ocaml-ssl-0.4.3.ebuild,v 1.1 2009/06/20 15:26:59 aballier Exp $
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL."
+SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
+HOMEPAGE="http://savonet.sourceforge.net/wiki/OCamlLibs"
+
+DEPEND="dev-libs/openssl"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README
+}