summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-18 02:12:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-18 02:12:44 +0000
commit9bf89c0a403ff527664c14720d6ab3f70d5b77a3 (patch)
tree0e5fe1cad7aadf6a109089247443b1e7a1c95e74 /dev-perl/AxKit
parent*** empty log message *** (diff)
downloadgentoo-2-9bf89c0a403ff527664c14720d6ab3f70d5b77a3.tar.gz
gentoo-2-9bf89c0a403ff527664c14720d6ab3f70d5b77a3.tar.bz2
gentoo-2-9bf89c0a403ff527664c14720d6ab3f70d5b77a3.zip
*** empty log message ***
Diffstat (limited to 'dev-perl/AxKit')
-rw-r--r--dev-perl/AxKit/AxKit-1.3.ebuild37
-rw-r--r--dev-perl/AxKit/files/digest-AxKit-1.31
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/AxKit/AxKit-1.3.ebuild b/dev-perl/AxKit/AxKit-1.3.ebuild
new file mode 100644
index 000000000000..6b9e62e43fae
--- /dev/null
+++ b/dev-perl/AxKit/AxKit-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.3.ebuild,v 1.1 2001/02/18 02:10:00 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The Apache AxKit Perl Module"
+SRC_URI="http://xml.sergeant.org/download/${A}"
+HOMEPAGE="http://xml.sergeant.org/"
+
+DEPEND=">=sys-devel/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile.PL Makefile.PL.orig
+ sed -e "s:0\.31_03:0.31:" Makefile.PL.orig > Makefile.PL
+}
+
+src_compile() {
+
+ perl Makefile.PL
+ try make
+ try make test
+}
+
+src_install () {
+
+ cd ${S}
+ try make PREFIX=${D}/usr install
+ dodoc ChangeLog MANIFEST README* TODO
+
+}
+
+
+
diff --git a/dev-perl/AxKit/files/digest-AxKit-1.3 b/dev-perl/AxKit/files/digest-AxKit-1.3
new file mode 100644
index 000000000000..4daeb039dd8d
--- /dev/null
+++ b/dev-perl/AxKit/files/digest-AxKit-1.3
@@ -0,0 +1 @@
+MD5 e0749282c66e7ce1b890a36b2da51d33 AxKit-1.3.tar.gz