summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-02-06 12:51:23 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-02-06 12:51:23 +0000
commite5db547a75bb24ecb80793caa84e2b98ba3c92f0 (patch)
treefde8b01bcf8e8f87af7cee09ccf476d297a2c603 /dev-perl/BSD-Resource
parentRemoved old versions. (diff)
downloadgentoo-2-e5db547a75bb24ecb80793caa84e2b98ba3c92f0.tar.gz
gentoo-2-e5db547a75bb24ecb80793caa84e2b98ba3c92f0.tar.bz2
gentoo-2-e5db547a75bb24ecb80793caa84e2b98ba3c92f0.zip
Bug 79329
(Portage version: 2.0.51-r13)
Diffstat (limited to 'dev-perl/BSD-Resource')
-rw-r--r--dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild10
-rw-r--r--dev-perl/BSD-Resource/ChangeLog11
-rw-r--r--dev-perl/BSD-Resource/files/portage_niceness.patch16
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild b/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild
index 3739115d3768..44318d21eced 100644
--- a/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild
+++ b/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild,v 1.7 2005/01/22 12:53:19 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild,v 1.8 2005/02/06 12:51:23 mcummings Exp $
-inherit perl-module
+inherit perl-module eutils
CATEGORY="dev-perl"
DESCRIPTION="Perl module for BSD process resource limit and priority functions"
@@ -14,3 +14,9 @@ SLOT="0"
KEYWORDS="x86 ~amd64 ~ppc sparc alpha"
IUSE=""
SRC_TEST="do"
+src_unpack(){
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/portage_niceness.patch
+}
+
diff --git a/dev-perl/BSD-Resource/ChangeLog b/dev-perl/BSD-Resource/ChangeLog
index 63d0851e5baa..9e8fe33d931c 100644
--- a/dev-perl/BSD-Resource/ChangeLog
+++ b/dev-perl/BSD-Resource/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-perl/BSD-Resource
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/ChangeLog,v 1.10 2005/01/22 12:53:19 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/ChangeLog,v 1.11 2005/02/06 12:51:23 mcummings Exp $
+
+ 06 Feb 2005; Michael Cummings <mcummings@gentoo.org>
+ +files/portage_niceness.patch, BSD-Resource-1.24.ebuild:
+ This update is to include a patch to deal with users employing the
+ PORTAGE_NICENESS variable. The getpriority tests that the module uses assume
+ that there is a priority of 0 for these tests - but if you've used niceness,
+ then that isn't the case and they will fail. Instead, we leave the old
+ values and adjust them to the niceness level if PORTAGE_NICENESS has been
+ set. Bug 79329.
22 Jan 2005; Gustavo Zacarias <gustavoz@gentoo.org>
BSD-Resource-1.24.ebuild:
diff --git a/dev-perl/BSD-Resource/files/portage_niceness.patch b/dev-perl/BSD-Resource/files/portage_niceness.patch
new file mode 100644
index 000000000000..c85836c9c09b
--- /dev/null
+++ b/dev-perl/BSD-Resource/files/portage_niceness.patch
@@ -0,0 +1,16 @@
+--- t/getpriority.t 1997-04-08 02:54:17.000000000 -0400
++++ t/getpriority.t.new 2005-02-06 07:37:07.092780984 -0500
+@@ -12,6 +12,13 @@
+
+ # AIX without BSD libs has 0..39 priorities, not -20..20.
+ $okpriopat = $Config{'osname'} eq 'aix' ? '0|19' : '0';
++my $priority = 0;
++if (defined($ENV{'PORTAGE_NICENESS'})) {
++ $priority = int($ENV{'PORTAGE_NICENESS'})
++} else {
++ $priority = 19
++}
++$okpriopat = defined($priority) ? "0|$priority" : '0';
+
+ $okpriopat = "^($okpriopat)";
+