summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-23 22:42:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-23 22:42:41 +0000
commit3137c001e8953af72b96fb738d16e3a51a8dc053 (patch)
tree2752de692bb2f509f607cf1366fe272927ad5c72 /dev-perl
parentforgot to remove old version (diff)
downloadgentoo-2-3137c001e8953af72b96fb738d16e3a51a8dc053.tar.gz
gentoo-2-3137c001e8953af72b96fb738d16e3a51a8dc053.tar.bz2
gentoo-2-3137c001e8953af72b96fb738d16e3a51a8dc053.zip
version bump to force remerge
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/ExtUtils-MakeMaker/ChangeLog13
-rw-r--r--dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.05-r1.ebuild57
-rw-r--r--dev-perl/ExtUtils-MakeMaker/files/digest-ExtUtils-MakeMaker-6.05-r11
3 files changed, 68 insertions, 3 deletions
diff --git a/dev-perl/ExtUtils-MakeMaker/ChangeLog b/dev-perl/ExtUtils-MakeMaker/ChangeLog
index 0d857b384992..2eb529e077f9 100644
--- a/dev-perl/ExtUtils-MakeMaker/ChangeLog
+++ b/dev-perl/ExtUtils-MakeMaker/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for dev-perl/ExtUtils-MakeMaker
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/ExtUtils-MakeMaker/ChangeLog,v 1.5 2002/10/13 11:25:24 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/ExtUtils-MakeMaker/ChangeLog,v 1.6 2002/10/23 22:42:41 seemant Exp $
+
+*ExtUtils-MakeMake-6.05-r1 (22 Oct 2002)
+
+ 23 Oct 2002; Seemant Kulleen <seemant@gentoo.org>
+ ExtUtils-MakeMaker-6.05-r1.ebuild files/digest-ExtUtils-MakeMaker-6.05 :
+
+ Version bump to force a remerge and fix a lot of dev-perl issues.
*ExtUtils-MakeMaker-6.05 (13 Oct 2002)
- 13 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ExtUtils-MakeMaker-6.05
- files/digest-ExtUtils-MakeMaker-6.05 :
+ 13 Oct 2002; Seemant Kulleen <seemant@gentoo.org>
+ ExtUtils-MakeMaker-6.05.ebuild files/digest-ExtUtils-MakeMaker-6.05 :
Version bump thanks to: wongs15@tartarus.uwa.edu.au (Steven Wong) in bug
#8980.
diff --git a/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.05-r1.ebuild b/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.05-r1.ebuild
new file mode 100644
index 000000000000..ba90331c8e77
--- /dev/null
+++ b/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.05-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.05-r1.ebuild,v 1.1 2002/10/23 22:42:41 seemant Exp $
+
+inherit perl-post
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MakeMaker Perl Module"
+SRC_URI="http://cpan.valueclick.com/modules/by-module/ExtUtils/${P}.tar.gz"
+HOMEPAGE="http://cpan.valueclick.com/modules/by-module/ExtUtils/${P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 sparc sparc64 ppc alpha"
+
+src_compile() {
+ perl Makefile.PL ${myconf} PREFIX=${D}/usr || die
+}
+
+src_install () {
+ perl-post_perlinfo
+ dodir ${POD_DIR}
+
+ test -z ${mytargets} && mytargets="install"
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLMAN2DIR=${D}/usr/share/man/man2 \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN4DIR=${D}/usr/share/man/man4 \
+ INSTALLMAN5DIR=${D}/usr/share/man/man5 \
+ INSTALLMAN6DIR=${D}/usr/share/man/man6 \
+ INSTALLMAN7DIR=${D}/usr/share/man/man7 \
+ INSTALLMAN8DIR=${D}/usr/share/man/man8 \
+ ${myinst} \
+ ${mytargets} || die
+
+ if [ -f ${D}${ARCH_LIB}/perllocal.pod ];
+ then
+ touch ${D}/${POD_DIR}/${P}.pod
+ sed -e "s:${D}::g" ${D}${ARCH_LIB}/perllocal.pod \
+ >> ${D}/${POD_DIR}/${P}.pod
+ touch ${D}/${POD_DIR}/${P}.pod.arch
+ cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.arch
+ rm -f ${D}/${ARCH_LIB}/perllocal.pod
+ fi
+ if [ -f ${D}${SITE_LIB}/perllocal.pod ];
+ then
+ touch ${D}/${POD_DIR}/${P}.pod
+ sed -e "s:${D}::g" ${D}${SITE_LIB}/perllocal.pod \
+ >> ${D}/${POD_DIR}/${P}.pod
+ touch ${D}/${POD_DIR}/${P}.pod.site
+ cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.site
+ rm -f ${D}/${SITE_LIB}/perllocal.pod
+ fi
+ dodoc Change* MANIFEST* README* ${mydoc}
+}
diff --git a/dev-perl/ExtUtils-MakeMaker/files/digest-ExtUtils-MakeMaker-6.05-r1 b/dev-perl/ExtUtils-MakeMaker/files/digest-ExtUtils-MakeMaker-6.05-r1
new file mode 100644
index 000000000000..ea0a957a9503
--- /dev/null
+++ b/dev-perl/ExtUtils-MakeMaker/files/digest-ExtUtils-MakeMaker-6.05-r1
@@ -0,0 +1 @@
+MD5 559896f9f222a750812c58b937a660f3 ExtUtils-MakeMaker-6.05.tar.gz 187528