summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2004-08-01 21:24:55 +0000
committerTom William Payne <twp@gentoo.org>2004-08-01 21:24:55 +0000
commite8bed0b83a3648ed80293af3a2479e8b2902c138 (patch)
tree34b4c642de4218be6b6d03dc3d9f31a16d0d8b61 /dev-php/smarty/smarty-2.6.3.ebuild
parentVersion bump. Bug # 55590. (Manifest recommit) (diff)
downloadgentoo-2-e8bed0b83a3648ed80293af3a2479e8b2902c138.tar.gz
gentoo-2-e8bed0b83a3648ed80293af3a2479e8b2902c138.tar.bz2
gentoo-2-e8bed0b83a3648ed80293af3a2479e8b2902c138.zip
Version bump. Bug # 55590.
Diffstat (limited to 'dev-php/smarty/smarty-2.6.3.ebuild')
-rw-r--r--dev-php/smarty/smarty-2.6.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/smarty/smarty-2.6.3.ebuild b/dev-php/smarty/smarty-2.6.3.ebuild
new file mode 100644
index 000000000000..fe15ba8227ad
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.3.ebuild,v 1.1 2004/08/01 21:24:55 twp Exp $
+
+MY_P=Smarty-${PV}
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~hppa ~ppc ~sparc ~x86"
+IUSE="doc"
+DEPEND="doc? ( dev-php/smarty-docs )"
+RDEPEND="virtual/php"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc [A-Z]*
+ mkdir -p ${D}/usr/lib/php
+ cp -a libs ${D}/usr/lib/php/Smarty
+}
+
+pkg_postinst() {
+ einfo "Smarty has been installed in /usr/lib/php/Smarty/."
+ einfo "To use it in your scripts, either"
+ einfo "1. define('SMARTY_DIR', \"/usr/lib/php/Smarty/\") in your scripts, or"
+ einfo "2. add /usr/lib/php/Smarty/ to includes= in /etc/php4/php.ini"
+}