summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-09-28 03:17:01 +0000
committerTom William Payne <twp@gentoo.org>2003-09-28 03:17:01 +0000
commit46cbd0ab1d9d592119d9342a86f550c2dbc34141 (patch)
treea8b55c2a49f68811dc17c54f2824e5bb3e604537 /dev-php/smarty
parentVersion bump (diff)
downloadgentoo-2-46cbd0ab1d9d592119d9342a86f550c2dbc34141.tar.gz
gentoo-2-46cbd0ab1d9d592119d9342a86f550c2dbc34141.tar.bz2
gentoo-2-46cbd0ab1d9d592119d9342a86f550c2dbc34141.zip
Version bump
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/ChangeLog7
-rw-r--r--dev-php/smarty/Manifest4
-rw-r--r--dev-php/smarty/files/digest-smarty-2.6.0_rc11
-rw-r--r--dev-php/smarty/metadata.xml9
-rw-r--r--dev-php/smarty/smarty-2.6.0_rc1.ebuild30
5 files changed, 48 insertions, 3 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index 63ea8128c76f..1379a79b3214 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/smarty
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.1 2003/05/11 13:14:35 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.2 2003/09/28 03:15:56 twp Exp $
+
+*smarty-2.6.0_rc1 (28 Sep 2003)
+
+ 28 Sep 2003; Tom Payne <twp@gentoo.org> smarty-2.6.0_rc1.ebuild :
+ Version bump. Added metadata.xml.
*smarty-2.5.0 (11 May 2003)
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index fde928698ad9..3964cea8ae43 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,6 +1,6 @@
-MD5 f6488454403e5eb26c6381d8cc49aca9 ChangeLog 457
+MD5 bc8dad0ec29de2f82f1106e8923d3b0f ChangeLog 457
MD5 43d5731b78f6d99e3ff4791b1ce3dc25 smarty-2.5.0.ebuild 996
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
-MD5 df90b3fc2351d94288a272f1d02fef92 smarty-2.6.0_rc1.ebuild 914
+MD5 4f6183b5f3503fa3dd69391a0eba19c8 smarty-2.6.0_rc1.ebuild 918
MD5 74ae938ca9097670a89c5f2ff6ad28f8 files/digest-smarty-2.5.0 133
MD5 d2e1f2edbf3fa357f3fabb573b96d430 files/digest-smarty-2.6.0_rc1 68
diff --git a/dev-php/smarty/files/digest-smarty-2.6.0_rc1 b/dev-php/smarty/files/digest-smarty-2.6.0_rc1
new file mode 100644
index 000000000000..e84ce5c9365e
--- /dev/null
+++ b/dev-php/smarty/files/digest-smarty-2.6.0_rc1
@@ -0,0 +1 @@
+MD5 df5172af7035f64a2c9e075cf4167733 Smarty-2.6.0-RC1.tar.gz 119551
diff --git a/dev-php/smarty/metadata.xml b/dev-php/smarty/metadata.xml
new file mode 100644
index 000000000000..d9bb4626fb2b
--- /dev/null
+++ b/dev-php/smarty/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>twp@gentoo.org</email>
+ <name>Tom Payne</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-php/smarty/smarty-2.6.0_rc1.ebuild b/dev-php/smarty/smarty-2.6.0_rc1.ebuild
new file mode 100644
index 000000000000..01e227321530
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.0_rc1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.0_rc1.ebuild,v 1.1 2003/09/28 03:15:56 twp Exp $
+
+MY_P=Smarty-${PV/_rc/-RC}
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips ppc sparc x86"
+IUSE="doc"
+DEPEND="virtual/php"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc [A-Z]*
+ insinto /usr/lib/php/Smarty
+ doins libs/*
+ insinto /usr/lib/php/Smarty/plugins
+ doins libs/plugins/*
+}
+
+pkg_postinst() {
+ einfo "Smarty has been installed in /usr/lib/php/Smarty."
+ einfo "To use it in your scripts, either"
+ einfo "1. define(SMARTY_DIR, \"/usr/lib/php/Smarty\") in your scripts, or"
+ einfo "2. add /usr/lib/php/Smarty to includes= in /etc/php4/php.ini"
+}