summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2004-12-17 01:38:38 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2004-12-17 01:38:38 +0000
commit066e38c57558d54df465dd5990b5d15083922428 (patch)
tree84cedf16ff73cd361b66ee426ad6503b74788d90 /dev-php
parentStable on sparc wrt #74547, solves #74627 (Manifest recommit) (diff)
downloadgentoo-2-066e38c57558d54df465dd5990b5d15083922428.tar.gz
gentoo-2-066e38c57558d54df465dd5990b5d15083922428.tar.bz2
gentoo-2-066e38c57558d54df465dd5990b5d15083922428.zip
STable on sparc wrt #74547, solves #74627
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog6
-rw-r--r--dev-php/mod_php/files/stdint.diff11
-rw-r--r--dev-php/mod_php/mod_php-4.3.10.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 0604c4e35cb0..d4619e5530a9 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.193 2004/12/16 10:42:33 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.194 2004/12/17 01:38:38 gustavoz Exp $
+
+ 16 Dec 2004; Gustavo Zacarias <gustavoz@gentoo.org> +files/stdint.diff,
+ mod_php-4.3.10.ebuild:
+ Stable on sparc wrt #74547, solves #74627
16 Dec 2004; Dylan Carlson <absinthe@gentoo.org> mod_php-4.3.10.ebuild:
Stable on amd64.
diff --git a/dev-php/mod_php/files/stdint.diff b/dev-php/mod_php/files/stdint.diff
new file mode 100644
index 000000000000..451d7fb44cf3
--- /dev/null
+++ b/dev-php/mod_php/files/stdint.diff
@@ -0,0 +1,11 @@
+diff -Nura php-4.3.10/Zend/zend_strtod.c php-4.3.10.stdint/Zend/zend_strtod.c
+--- php-4.3.10/Zend/zend_strtod.c 2004-12-14 05:35:26.000000000 -0300
++++ php-4.3.10.stdint/Zend/zend_strtod.c 2004-12-16 15:33:47.000000000 -0300
+@@ -128,6 +128,7 @@
+ #endif
+
+ #if defined(__sparc__) || defined(__ppc__)
++#include <stdint.h>
+ #define u_int32_t uint32_t
+ #endif
+
diff --git a/dev-php/mod_php/mod_php-4.3.10.ebuild b/dev-php/mod_php/mod_php-4.3.10.ebuild
index c4966c95c861..b358a88e5b33 100644
--- a/dev-php/mod_php/mod_php-4.3.10.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.10.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.10.ebuild,v 1.3 2004/12/16 10:42:33 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.10.ebuild,v 1.4 2004/12/17 01:38:38 gustavoz Exp $
IUSE="${IUSE} apache2"
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa amd64 ~ia64 ~s390 ppc64 ~mips"
+KEYWORDS="x86 ~ppc sparc ~alpha ~hppa amd64 ~ia64 ~s390 ppc64 ~mips"
detectapache() {
local domsg=
@@ -75,6 +75,7 @@ src_unpack() {
if [ "${ARCH}" == "amd64" ] ; then
epatch ${FILESDIR}/mod_php-4.3.4-amd64hack.diff
fi
+ [ "${ARCH}" == "sparc" ] && epatch ${FILESDIR}/stdint.diff
# bug fix for security problem - bug #39952
# second revision as the apache2 stuff was resolved upstream