summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-18 06:21:35 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-18 06:21:35 +0000
commitc69678e2e82018766a98bb695ab9334a46ce228b (patch)
treeff65f6a7253c81140c8075d09d417133e9272633 /dev-php
parentNew package. Needs testing on platforms other than x86. Fixes #6076 (diff)
downloadgentoo-2-c69678e2e82018766a98bb695ab9334a46ce228b.tar.gz
gentoo-2-c69678e2e82018766a98bb695ab9334a46ce228b.tar.bz2
gentoo-2-c69678e2e82018766a98bb695ab9334a46ce228b.zip
Readded png support. fixes #8882
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog10
-rw-r--r--dev-php/php/php-4.2.2-r1.ebuild3
-rw-r--r--dev-php/php/php-4.2.3.ebuild3
3 files changed, 13 insertions, 3 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index f0aff4a0c391..de7b8fe5d636 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.15 2002/09/27 11:32:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.16 2002/10/18 06:21:35 rphillips Exp $
*php-4.2.3 (10 Sep 2002)
+ 17 Oct 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.3.ebuild :
+
+ Added png support
+
12 Sep 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.3.ebuild :
Added xmlrpc to 'xml' use flag. Fixes #7811
@@ -14,6 +18,10 @@
*php-4.2.2-r1 (18 Aug 2002)
+ 17 Oct 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.2-r1.ebuild :
+
+ Readded png support
+
27 Sep 2002; Seemant Kulleen <seemant@gentoo.org> php-4.2.2-r1.ebuild :
--enable-readline -> --with-readline. Thanks to ska in #gentoo-dev
diff --git a/dev-php/php/php-4.2.2-r1.ebuild b/dev-php/php/php-4.2.2-r1.ebuild
index b4036789877d..9f523a53d81b 100644
--- a/dev-php/php/php-4.2.2-r1.ebuild
+++ b/dev-php/php/php-4.2.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.14 2002/10/17 01:08:38 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.15 2002/10/18 06:21:35 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg readline ssl gd #java mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb firebird pam oci8"
@@ -112,6 +112,7 @@ src_compile() {
else
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
+ use png && myconf="${myconf} --with-png-dir=/usr"
fi
# optional support for oracle oci8
diff --git a/dev-php/php/php-4.2.3.ebuild b/dev-php/php/php-4.2.3.ebuild
index 18158947d981..fcbc4802451a 100644
--- a/dev-php/php/php-4.2.3.ebuild
+++ b/dev-php/php/php-4.2.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.3.ebuild,v 1.5 2002/10/05 05:39:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.3.ebuild,v 1.6 2002/10/18 06:21:35 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg readline ssl gd oci8 mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
@@ -116,6 +116,7 @@ src_compile() {
else
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
+ use png && myconf="${myconf} --with-png-dir=/usr"
fi
# optional support for oracle oci8