summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-06-18 07:20:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-06-18 07:20:25 +0000
commitf7ce8661bf805e67f889f7413e3e43e296b1dec0 (patch)
treef022971c61095cfa92ff8418314a4db705280fd9 /dev-php
parentFix bug number in ChangeLog. (Manifest recommit) (diff)
downloadgentoo-2-f7ce8661bf805e67f889f7413e3e43e296b1dec0.tar.gz
gentoo-2-f7ce8661bf805e67f889f7413e3e43e296b1dec0.tar.bz2
gentoo-2-f7ce8661bf805e67f889f7413e3e43e296b1dec0.zip
fix bug #49020 and bug #54086.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog5
-rw-r--r--dev-php/mod_php/files/70_mod_php.conf17
2 files changed, 15 insertions, 7 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 4c8b11e5be66..3dcd920cfaad 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.150 2004/06/11 10:40:17 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.151 2004/06/18 07:20:25 robbat2 Exp $
+
+ 18 Jun 2004; Robin H. Johnson <robbat2@gentoo.org> files/70_mod_php.conf:
+ fix bug #49020 and bug #54086.
11 Jun 2004; Guy Martin <gmsoft@gentoo.org> mod_php-4.3.6-r2.ebuild:
Marked stable on hppa.
diff --git a/dev-php/mod_php/files/70_mod_php.conf b/dev-php/mod_php/files/70_mod_php.conf
index fab4c6e8cc08..ed01744f3c9b 100644
--- a/dev-php/mod_php/files/70_mod_php.conf
+++ b/dev-php/mod_php/files/70_mod_php.conf
@@ -1,7 +1,7 @@
<IfDefine PHP4>
# Load the module first
- <IfModule !mod_php4.c>
+ <IfModule !sapi_apache2.c>
LoadModule php4_module extramodules/libphp4.so
</IfModule>
@@ -16,23 +16,28 @@
# Fix some bugs
<Files *.php>
- LimitRequestBody 524288
+ # keep this the same size as post_max_size in php.ini
+ LimitRequestBody 8388608
RequestHeader unset If-Modified-Since
</Files>
<Files *.php3>
- LimitRequestBody 524288
+ # keep this the same size as post_max_size in php.ini
+ LimitRequestBody 8388608
RequestHeader unset If-Modified-Since
</Files>
<Files *.php4>
- LimitRequestBody 524288
+ # keep this the same size as post_max_size in php.ini
+ LimitRequestBody 8388608
RequestHeader unset If-Modified-Since
</Files>
<Files *.phps>
- LimitRequestBody 524288
+ # keep this the same size as post_max_size in php.ini
+ LimitRequestBody 8388608
RequestHeader unset If-Modified-Since
</Files>
<Files *.phtml>
- LimitRequestBody 524288
+ # keep this the same size as post_max_size in php.ini
+ LimitRequestBody 8388608
RequestHeader unset If-Modified-Since
</Files>