summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-11-27 21:55:06 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-11-27 21:55:06 +0000
commitb96fb52056371bbfae09ad262f15fca7cc68ca16 (patch)
tree2663fa990f1b17d6efba863a64266033d1904b99 /dev-python/PyQt
parentThis version work, have nls support, and is installed as recommended by the a... (diff)
downloadgentoo-2-b96fb52056371bbfae09ad262f15fca7cc68ca16.tar.gz
gentoo-2-b96fb52056371bbfae09ad262f15fca7cc68ca16.tar.bz2
gentoo-2-b96fb52056371bbfae09ad262f15fca7cc68ca16.zip
New versions of PyQT 3.0, both for QT >=2.3.1 and QT 3.0
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/files/digest-qt2.3.1_PyQt-3.01
-rw-r--r--dev-python/PyQt/files/digest-qt3.0.0_PyQt-3.02
-rw-r--r--dev-python/PyQt/qt2.3.1_PyQt-3.0.ebuild29
-rw-r--r--dev-python/PyQt/qt3.0.0_PyQt-3.0.ebuild39
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/PyQt/files/digest-qt2.3.1_PyQt-3.0 b/dev-python/PyQt/files/digest-qt2.3.1_PyQt-3.0
new file mode 100644
index 000000000000..b69a36586aea
--- /dev/null
+++ b/dev-python/PyQt/files/digest-qt2.3.1_PyQt-3.0
@@ -0,0 +1 @@
+MD5 52f3b020c469c08aace8e6bfce8641d3 PyQt-3.0-Qt-2.3.1.tar.gz 2084864
diff --git a/dev-python/PyQt/files/digest-qt3.0.0_PyQt-3.0 b/dev-python/PyQt/files/digest-qt3.0.0_PyQt-3.0
new file mode 100644
index 000000000000..20a8efa25d89
--- /dev/null
+++ b/dev-python/PyQt/files/digest-qt3.0.0_PyQt-3.0
@@ -0,0 +1,2 @@
+MD5 146bb111ea6bec8f16d14d1026b77759 PyQt-3.0-Qt-3.0.0-patch.1 4096
+MD5 5e227ea0b0ad132f9eafa55fb7f90ea8 PyQt-3.0-Qt-3.0.0.tar.gz 2375680
diff --git a/dev-python/PyQt/qt2.3.1_PyQt-3.0.ebuild b/dev-python/PyQt/qt2.3.1_PyQt-3.0.ebuild
new file mode 100644
index 000000000000..1f217850e57c
--- /dev/null
+++ b/dev-python/PyQt/qt2.3.1_PyQt-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/qt2.3.1_PyQt-3.0.ebuild,v 1.1 2001/11/27 21:55:06 verwilst Exp $
+
+S="${WORKDIR}/PyQt-3.0"
+DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit."
+SRC_URI="http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-2.3.1.tar.gz"
+HOMEPAGE="http://www.thekompany.com/projects/pykde/"
+
+DEPEND="virtual/glibc
+ >=x11-libs/qt-x11-2.3
+ =dev-python/sip-3.0
+ virtual/python"
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-doc-install=/usr/share/doc
+ assert
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-doc || die
+}
diff --git a/dev-python/PyQt/qt3.0.0_PyQt-3.0.ebuild b/dev-python/PyQt/qt3.0.0_PyQt-3.0.ebuild
new file mode 100644
index 000000000000..795f49fc37d9
--- /dev/null
+++ b/dev-python/PyQt/qt3.0.0_PyQt-3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/qt3.0.0_PyQt-3.0.ebuild,v 1.1 2001/11/27 21:55:06 verwilst Exp $
+
+S="${WORKDIR}/PyQt-3.0"
+DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit."
+SRC_URI="http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0.tar.gz
+ http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0-patch.1"
+HOMEPAGE="http://www.thekompany.com/projects/pykde/"
+
+DEPEND="virtual/glibc
+ >=x11-libs/qt-x11-3.0
+ =dev-python/sip-3.0
+ virtual/python"
+
+src_unpack() {
+
+ unpack PyQt-3.0-Qt-3.0.0.tar.gz
+ cd ${WORKDIR}
+ patch -p0 < ${DISTDIR}/PyQt-3.0-Qt-3.0.0-patch.1
+ cd ${S}
+
+}
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-doc-install=/usr/share/doc
+ assert
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-doc || die
+}