summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-09 08:29:27 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-09 08:29:27 +0000
commit2a6f359b8fce5f490e4931ea1e5a4145b8a87335 (patch)
tree54a8705e6ee96fa871e55c356e32648626df5fd4 /dev-python/datashape
parentVersion bump to 4.84 RC2 (diff)
downloadgentoo-2-2a6f359b8fce5f490e4931ea1e5a4145b8a87335.tar.gz
gentoo-2-2a6f359b8fce5f490e4931ea1e5a4145b8a87335.tar.bz2
gentoo-2-2a6f359b8fce5f490e4931ea1e5a4145b8a87335.zip
bump; drop py3.2 add py3.4, upgrade doc build
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/datashape')
-rw-r--r--dev-python/datashape/ChangeLog7
-rw-r--r--dev-python/datashape/datashape-0.3.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/datashape/ChangeLog b/dev-python/datashape/ChangeLog
index 38ced9835cea..9cd4c3d38baa 100644
--- a/dev-python/datashape/ChangeLog
+++ b/dev-python/datashape/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/datashape
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.3 2014/05/26 07:43:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.4 2014/08/09 08:29:27 idella4 Exp $
+
+*datashape-0.3.0 (09 Aug 2014)
+
+ 09 Aug 2014; Ian Delaney <idella4@gentoo.org> +datashape-0.3.0.ebuild:
+ bump; drop py3.2 add py3.4, upgrade doc build
*datashape-0.2.0 (26 May 2014)
diff --git a/dev-python/datashape/datashape-0.3.0.ebuild b/dev-python/datashape/datashape-0.3.0.ebuild
new file mode 100644
index 000000000000..3f7d19d727ef
--- /dev/null
+++ b/dev-python/datashape/datashape-0.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.3.0.ebuild,v 1.1 2014/08/09 08:29:27 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/ContinuumIO/datashape/issues/78
+ cd "${BUILD_DIR}"/lib* || die
+ nosetests -v || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}