summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-11-05 00:18:10 +0000
committerMike Gilbert <floppym@gentoo.org>2014-11-05 00:18:10 +0000
commit428cd51dbf66e06aa7186a0a5959f6e6dae7b733 (patch)
tree22c068396c948026e9be159db23a85879d724d97 /dev-python/httplib2
parentSet higher memory requirements. Translate using PyPy by default. Add USE=low-... (diff)
downloadgentoo-2-428cd51dbf66e06aa7186a0a5959f6e6dae7b733.tar.gz
gentoo-2-428cd51dbf66e06aa7186a0a5959f6e6dae7b733.tar.bz2
gentoo-2-428cd51dbf66e06aa7186a0a5959f6e6dae7b733.zip
Depend on setuptools. Remove old.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog6
-rw-r--r--dev-python/httplib2/httplib2-0.6.0.ebuild36
-rw-r--r--dev-python/httplib2/httplib2-0.7.6.ebuild6
-rw-r--r--dev-python/httplib2/httplib2-0.7.7.ebuild30
-rw-r--r--dev-python/httplib2/httplib2-0.8.ebuild4
5 files changed, 12 insertions, 70 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 14a28d5b3cc8..41808a0194df 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/httplib2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.43 2014/05/24 09:53:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.44 2014/11/05 00:18:10 floppym Exp $
+
+ 05 Nov 2014; Mike Gilbert <floppym@gentoo.org> -httplib2-0.6.0.ebuild,
+ -httplib2-0.7.7.ebuild, httplib2-0.7.6.ebuild, httplib2-0.8.ebuild:
+ Depend on setuptools. Remove old.
24 May 2014; Ian Delaney <idella4@gentoo.org> httplib2-0.8.ebuild:
add pypy support
diff --git a/dev-python/httplib2/httplib2-0.6.0.ebuild b/dev-python/httplib2/httplib2-0.6.0.ebuild
deleted file mode 100644
index d5f31d08775a..000000000000
--- a/dev-python/httplib2/httplib2-0.6.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.6.0.ebuild,v 1.10 2010/10/09 10:38:53 ssuominen Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
-SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_install() {
- distutils_src_install
-
- dodoc README
- newdoc python3/README README-python3
-}
-
-src_test() {
- testing() {
- cd "$S/python${PYTHON_ABI:0:1}"
- "$(PYTHON)" httplib2test.py
- cd ../..
- }
- python_execute_function testing
-}
diff --git a/dev-python/httplib2/httplib2-0.7.6.ebuild b/dev-python/httplib2/httplib2-0.7.6.ebuild
index c25d68d51604..898f2aa43a9d 100644
--- a/dev-python/httplib2/httplib2-0.7.6.ebuild
+++ b/dev-python/httplib2/httplib2-0.7.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.6.ebuild,v 1.8 2012/12/30 20:25:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.6.ebuild,v 1.9 2014/11/05 00:18:10 floppym Exp $
EAPI="4"
PYTHON_DEPEND="2 3:3.2"
@@ -20,6 +20,8 @@ SLOT="0"
KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE=""
+DEPEND="dev-python/setuptools"
+
src_test() {
testing() {
pushd "python$(python_get_version --major)" > /dev/null
diff --git a/dev-python/httplib2/httplib2-0.7.7.ebuild b/dev-python/httplib2/httplib2-0.7.7.ebuild
deleted file mode 100644
index 335d8192506f..000000000000
--- a/dev-python/httplib2/httplib2-0.7.7.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.7.ebuild,v 1.2 2013/09/05 18:46:31 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
-SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-macos ~x86-linux"
-IUSE=""
-
-# tests connect to random remote sites
-RESTRICT="test"
-
-python_test() {
- if [[ ${EPYTHON} == python2.* ]] ; then
- cd python2
- else
- cd python3
- fi
-
- "${PYTHON}" httplib2test.py || die
-}
diff --git a/dev-python/httplib2/httplib2-0.8.ebuild b/dev-python/httplib2/httplib2-0.8.ebuild
index 278078723f9a..1a7b9dc97917 100644
--- a/dev-python/httplib2/httplib2-0.8.ebuild
+++ b/dev-python/httplib2/httplib2-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.8.ebuild,v 1.4 2014/05/24 09:53:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.8.ebuild,v 1.5 2014/11/05 00:18:10 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
@@ -16,6 +16,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-macos ~x86-linux"
IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
# tests connect to random remote sites
RESTRICT="test"