summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-10-07 04:03:49 +0000
committerMike Gilbert <floppym@gentoo.org>2012-10-07 04:03:49 +0000
commit3822aa77339bb8e4b17b7cef738c8fc24f5c951a (patch)
treeea6b4376d9cb9f46920c8c4413925642db564f6a /dev-python/python-docs
parentAdd missing dependency over pkgconfig. Closes bug #380667. (diff)
downloadgentoo-2-3822aa77339bb8e4b17b7cef738c8fc24f5c951a.tar.gz
gentoo-2-3822aa77339bb8e4b17b7cef738c8fc24f5c951a.tar.bz2
gentoo-2-3822aa77339bb8e4b17b7cef738c8fc24f5c951a.zip
Use dohtml. Patch by Arfrever.
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog7
-rw-r--r--dev-python/python-docs/python-docs-2.6.8.ebuild6
-rw-r--r--dev-python/python-docs/python-docs-2.7.3.ebuild6
-rw-r--r--dev-python/python-docs/python-docs-3.1.5.ebuild6
-rw-r--r--dev-python/python-docs/python-docs-3.2.3.ebuild6
-rw-r--r--dev-python/python-docs/python-docs-3.3.0.ebuild6
6 files changed, 16 insertions, 21 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index 6cd8f1e43b8c..fabebb74e1cc 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.166 2012/09/29 18:23:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.167 2012/10/07 04:03:49 floppym Exp $
+
+ 07 Oct 2012; Mike Gilbert <floppym@gentoo.org> python-docs-2.6.8.ebuild,
+ python-docs-2.7.3.ebuild, python-docs-3.1.5.ebuild, python-docs-3.2.3.ebuild,
+ python-docs-3.3.0.ebuild:
+ Use dohtml. Patch by Arfrever.
*python-docs-3.3.0 (29 Sep 2012)
diff --git a/dev-python/python-docs/python-docs-2.6.8.ebuild b/dev-python/python-docs/python-docs-2.6.8.ebuild
index 346e46a41bd5..da3fc2ebefdb 100644
--- a/dev-python/python-docs/python-docs-2.6.8.ebuild
+++ b/dev-python/python-docs/python-docs-2.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.8.ebuild,v 1.1 2012/09/29 18:13:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.8.ebuild,v 1.2 2012/10/07 04:03:49 floppym Exp $
EAPI="3"
@@ -19,9 +19,7 @@ RDEPEND=""
S="${WORKDIR}/python-${PV}-docs-html"
src_install() {
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
-
+ dohtml -A xml -r ./
echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}
diff --git a/dev-python/python-docs/python-docs-2.7.3.ebuild b/dev-python/python-docs/python-docs-2.7.3.ebuild
index b3738a9107fd..b106d53f5c8a 100644
--- a/dev-python/python-docs/python-docs-2.7.3.ebuild
+++ b/dev-python/python-docs/python-docs-2.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.7.3.ebuild,v 1.1 2012/09/29 18:13:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.7.3.ebuild,v 1.2 2012/10/07 04:03:49 floppym Exp $
EAPI="3"
@@ -19,9 +19,7 @@ RDEPEND=""
S="${WORKDIR}/python-${PV}-docs-html"
src_install() {
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
-
+ dohtml -A xml -r ./
echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}
diff --git a/dev-python/python-docs/python-docs-3.1.5.ebuild b/dev-python/python-docs/python-docs-3.1.5.ebuild
index 8a3f64144e98..b92ad5b9df81 100644
--- a/dev-python/python-docs/python-docs-3.1.5.ebuild
+++ b/dev-python/python-docs/python-docs-3.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.5.ebuild,v 1.1 2012/09/29 18:13:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.5.ebuild,v 1.2 2012/10/07 04:03:49 floppym Exp $
EAPI="3"
@@ -19,9 +19,7 @@ RDEPEND=""
S="${WORKDIR}/python-${PV}-docs-html"
src_install() {
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
-
+ dohtml -A xml -r ./
echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}
diff --git a/dev-python/python-docs/python-docs-3.2.3.ebuild b/dev-python/python-docs/python-docs-3.2.3.ebuild
index 35b2ed18b436..c5393b813af3 100644
--- a/dev-python/python-docs/python-docs-3.2.3.ebuild
+++ b/dev-python/python-docs/python-docs-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.2.3.ebuild,v 1.1 2012/09/29 18:13:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.2.3.ebuild,v 1.2 2012/10/07 04:03:49 floppym Exp $
EAPI="3"
@@ -19,9 +19,7 @@ RDEPEND=""
S="${WORKDIR}/python-${PV}-docs-html"
src_install() {
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
-
+ dohtml -A xml -r ./
echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}
diff --git a/dev-python/python-docs/python-docs-3.3.0.ebuild b/dev-python/python-docs/python-docs-3.3.0.ebuild
index 93ff548b402c..f39d869ca425 100644
--- a/dev-python/python-docs/python-docs-3.3.0.ebuild
+++ b/dev-python/python-docs/python-docs-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.3.0.ebuild,v 1.2 2012/09/29 18:23:56 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.3.0.ebuild,v 1.3 2012/10/07 04:03:49 floppym Exp $
EAPI="3"
@@ -27,9 +27,7 @@ pkg_setup() {
}
src_install() {
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
-
+ dohtml -A xml -r ./
echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}