summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-09-15 20:22:35 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-09-15 20:22:35 +0000
commit0605b468aea9e928988b311ad2c1022f90cb1a17 (patch)
tree5d85da719298da0ef3a76e255f7a660b15ea3dc9 /dev-python/sip
parentunmasked all old koffice releases, since 1.2 is out now (diff)
downloadgentoo-2-0605b468aea9e928988b311ad2c1022f90cb1a17.tar.gz
gentoo-2-0605b468aea9e928988b311ad2c1022f90cb1a17.tar.bz2
gentoo-2-0605b468aea9e928988b311ad2c1022f90cb1a17.zip
new version, masked
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog4
-rw-r--r--dev-python/sip/files/digest-sip-3.41
-rw-r--r--dev-python/sip/sip-3.4.ebuild32
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index fa95e075cc8b..bd58bef4d582 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for dev-python/sip
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.4 2002/07/25 21:12:17 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.5 2002/09/15 20:22:35 verwilst Exp $
+
+*sip-3.4 (15 Sept 2002) Bart Verwilst <verwilst@gentoo.org>
*sip-3.3.2 (25 July 2002) Bart Verwilst <verwilst@gentoo.org>
diff --git a/dev-python/sip/files/digest-sip-3.4 b/dev-python/sip/files/digest-sip-3.4
new file mode 100644
index 000000000000..b7f5d7023b16
--- /dev/null
+++ b/dev-python/sip/files/digest-sip-3.4
@@ -0,0 +1 @@
+MD5 ab0b69e48f7e7c27bb099304bddf3985 sip-x11-gpl-3.4.tar.gz 159038
diff --git a/dev-python/sip/sip-3.4.ebuild b/dev-python/sip/sip-3.4.ebuild
new file mode 100644
index 000000000000..87704d0a5318
--- /dev/null
+++ b/dev-python/sip/sip-3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.4.ebuild,v 1.1 2002/09/15 20:22:35 verwilst Exp $
+
+S=${WORKDIR}/${PN}-x11-gpl-${PV}
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${PN}-x11-gpl-${PV}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="x86 sparc sparc64"
+DEPEND="virtual/glibc
+ >=dev-lang/python-2.2.1"
+
+src_compile(){
+
+ cd ${S}
+ chmod +x build.py
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/lib/python2.2/site-packages
+ python build.py -l qt-mt -b ${D}/usr/bin -d ${D}/usr/lib/python2.2/site-packages \
+ -e ${D}/usr/include/python2.2
+ make
+}
+
+src_install() {
+
+ mkdir -p ${D}/usr/include/python2.2
+ make DESTDIR=${D} install || die
+ dodoc NEWS README THANKS
+
+}