summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-12-27 06:39:32 +0000
committerMike Gilbert <floppym@gentoo.org>2011-12-27 06:39:32 +0000
commitc6536ef6927c6db704a9f31e569d142a62dda156 (patch)
treeac5a7c24bade27ab3cd3f4b3cb1ccfda5d3c25d3 /dev-python/twisted
parentUse twistedmatrix.com/Releases in SRC_URI; tmrc.mit.edu does not have tarball... (diff)
downloadgentoo-2-c6536ef6927c6db704a9f31e569d142a62dda156.tar.gz
gentoo-2-c6536ef6927c6db704a9f31e569d142a62dda156.tar.bz2
gentoo-2-c6536ef6927c6db704a9f31e569d142a62dda156.zip
Version bump for bug 395825 by Ian Delaney. Bits and pieces by Arfrever.
(Portage version: 2.2.0_alpha83/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/twisted-11.1.0.ebuild102
2 files changed, 108 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index dbddbc95719e..69c93e37cf97 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.149 2011/07/17 10:57:03 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.150 2011/12/27 06:39:32 floppym Exp $
+
+*twisted-11.1.0 (27 Dec 2011)
+
+ 27 Dec 2011; Mike Gilbert <floppym@gentoo.org> +twisted-11.1.0.ebuild:
+ Version bump for bug 395825 by Ian Delaney. Bits and pieces by Arfrever.
17 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> twisted-11.0.0.ebuild:
ppc64 stable wrt #366131
diff --git a/dev-python/twisted/twisted-11.1.0.ebuild b/dev-python/twisted/twisted-11.1.0.ebuild
new file mode 100644
index 000000000000..9f8ae4555bfb
--- /dev/null
+++ b/dev-python/twisted/twisted-11.1.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-11.1.0.ebuild,v 1.1 2011/12/27 06:39:32 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Core"
+
+inherit eutils twisted versionator
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="crypt gtk serial"
+
+DEPEND="net-zope/zope-interface
+ crypt? ( >=dev-python/pyopenssl-0.10 )
+ gtk? ( dev-python/pygtk:2 )
+ serial? ( dev-python/pyserial )"
+RDEPEND="${DEPEND}"
+
+DOCS="CREDITS NEWS README"
+
+src_prepare(){
+ distutils_src_prepare
+
+ # Give a load-sensitive test a better chance of succeeding.
+ epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
+
+ # Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
+ epatch "${FILESDIR}/${PN}-9.0.0-respect_TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE.patch"
+
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed \
+ -e "s/test_newPluginsOnReadOnlyPath/_&/" \
+ -e "s/test_deployedMode/_&/" \
+ -i twisted/test/test_plugin.py
+ fi
+}
+
+src_test() {
+ testing() {
+ local exit_status="0"
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with $(python_get_implementation) $(python_get_version)"
+
+ pushd "${T}/tests${EPREFIX}$(python_get_sitedir)" > /dev/null || die
+
+ # Skip broken tests.
+ sed -e "s/test_buildAllTarballs/_&/" -i twisted/python/test/test_release.py || die "sed failed"
+
+ # http://twistedmatrix.com/trac/ticket/5375
+ sed -e "/class ZshIntegrationTestCase/,/^$/d" -i twisted/scripts/test/test_scripts.py || die "sed failed"
+
+ # Prevent it from pulling in plugins from already installed twisted packages.
+ rm -f twisted/plugins/__init__.py
+
+ # An empty file doesn't work because the tests check for doc strings in all packages.
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ if ! PYTHONPATH="." "${T}/tests${EPREFIX}/usr/bin/trial" twisted; then
+ if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
+ die "Tests failed with $(python_get_implementation) $(python_get_version)"
+ else
+ exit_status="1"
+ fi
+ fi
+
+ popd > /dev/null || die
+ rm -fr "${T}/tests"
+ return "${exit_status}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/trial"
+
+ postinstallational_preparation() {
+ touch "${ED}$(python_get_sitedir)/Twisted-${PV}-py$(python_get_version).egg-info"
+
+ # Delete dropin.cache to avoid collisions.
+ # dropin.cache is regenerated in pkg_postinst().
+ rm -f "${ED}$(python_get_sitedir)/twisted/plugins/dropin.cache"
+ }
+ python_execute_function -q postinstallational_preparation
+
+ # Don't install index.xhtml page.
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+}