summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-03-14 06:52:45 +0000
committerTod Neidt <tod@gentoo.org>2002-03-14 06:52:45 +0000
commit2fdd83ff0c18a2f01d13010a4ed20bb1e4cc525f (patch)
tree1e47a8771137231386a0b63ada18c1f1a439a553 /dev-python
parentLots of fixes to bring our pcmcia up to snuff. Read the changelog. (diff)
downloadgentoo-2-2fdd83ff0c18a2f01d13010a4ed20bb1e4cc525f.tar.gz
gentoo-2-2fdd83ff0c18a2f01d13010a4ed20bb1e4cc525f.tar.bz2
gentoo-2-2fdd83ff0c18a2f01d13010a4ed20bb1e4cc525f.zip
Updated version. Was a small change of build script name from setup_all.py to setup.py
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Numeric/ChangeLog8
-rw-r--r--dev-python/Numeric/Numeric-21.0.ebuild42
-rw-r--r--dev-python/Numeric/files/digest-Numeric-21.01
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/Numeric/ChangeLog b/dev-python/Numeric/ChangeLog
index c31206012f00..f743bfbcb1b5 100644
--- a/dev-python/Numeric/ChangeLog
+++ b/dev-python/Numeric/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-python/Numeric
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/ChangeLog,v 1.2 2002/03/14 06:52:41 tod Exp $
+*Numeric-21.0 (14 Mar 2002)
+
+ 14 Mar 2002; T.Neidt <tod@gentoo.org> ChangeLog, Numeric-21.0.ebuild :
+
+ Updated version.
+
*Numeric-20.3 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/dev-python/Numeric/Numeric-21.0.ebuild b/dev-python/Numeric/Numeric-21.0.ebuild
new file mode 100644
index 000000000000..3bfd32c4bb40
--- /dev/null
+++ b/dev-python/Numeric/Numeric-21.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-19.0.0.ebuild,v 1.3 2001/08/31 03:23:38 pm Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="numerical python module"
+SRC_URI="http://prdownloads.sourceforge.net/numpy/${P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+src_compile() {
+
+#The ebuild as is uses a small local version of BLAS and LAPACK provided
+#by the Numeric package. If I ever get ATLAS and LAPACK ebuilds finished,
+#we'll need to edit (sed) setup.py to use the real libraries.
+
+ python setup.py build || die
+
+}
+
+src_install() {
+
+ python setup.py install --prefix=${D}/usr || die
+
+ dodoc MANIFEST PKG-INFO README
+
+#grab python verision so ebuild doesn't depend on it
+ local pv
+ pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+
+#Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${pv}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+
diff --git a/dev-python/Numeric/files/digest-Numeric-21.0 b/dev-python/Numeric/files/digest-Numeric-21.0
new file mode 100644
index 000000000000..6838a3e193a9
--- /dev/null
+++ b/dev-python/Numeric/files/digest-Numeric-21.0
@@ -0,0 +1 @@
+MD5 0684989aa6dfa4eba616ca7e36c524fd Numeric-21.0.tar.gz 718118