summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-08-27 15:54:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-08-27 15:54:01 +0000
commit90bc44e401134c403a7393bf3f65f6ef924a8a99 (patch)
treee1174d006d761a25ba7a62ac56bb186e617912ea /dev-python
parentVersion bump (diff)
downloadgentoo-2-90bc44e401134c403a7393bf3f65f6ef924a8a99.tar.gz
gentoo-2-90bc44e401134c403a7393bf3f65f6ef924a8a99.tar.bz2
gentoo-2-90bc44e401134c403a7393bf3f65f6ef924a8a99.zip
Version bump
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/Manifest4
-rw-r--r--dev-python/sip/files/digest-sip-3.81
-rw-r--r--dev-python/sip/files/license-3.8.diff34
-rw-r--r--dev-python/sip/sip-3.8.ebuild49
5 files changed, 92 insertions, 3 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 3381edb65d28..79837a1f68e6 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.14 2003/07/31 03:10:05 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.15 2003/08/27 15:53:50 caleb Exp $
+
+*sip-3.8 (27 Aug 2003)
+
+ 27 Aug 2003; Caleb Tennis <caleb@gentoo.org> sip-3.8.ebuild:
+ Version bump
*sip-3.7 (30 Jul 2003)
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 2a1ea815446a..be4c3e678d4b 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,8 +1,8 @@
MD5 7bc22db772ade4e5119bb41e89360af3 sip-3.6.ebuild 1148
-MD5 021505e7c628d93f0c2451c74c4de1cc sip-3.8.ebuild 1149
+MD5 79ee8ae28f26a33b7533604c9851472b sip-3.8.ebuild 1149
MD5 2e90d26390ed13cd2a38d6be47c10f6b sip-3.5.ebuild 1147
MD5 68afdd4be32a4784e783045508473bfd sip-3.7.ebuild 1149
-MD5 3d10a42f18e883799a5a3dc9128c1a25 ChangeLog 1698
+MD5 8f73bc625ca5c07716bb5c71bdd51fea ChangeLog 1801
MD5 811c07ba7510a315382249fc3adb44fc metadata.xml 175
MD5 ea94cf729c92330a5d8a6d508361fd1c files/license-3.5.diff 1052
MD5 3d3910def0f161c87391dd758512fc18 files/license-3.6.diff 1037
diff --git a/dev-python/sip/files/digest-sip-3.8 b/dev-python/sip/files/digest-sip-3.8
new file mode 100644
index 000000000000..9093f9dd6006
--- /dev/null
+++ b/dev-python/sip/files/digest-sip-3.8
@@ -0,0 +1 @@
+MD5 2144b29adca9ff7b3b03de266da6c2eb sip-x11-gpl-3.8.tar.gz 179221
diff --git a/dev-python/sip/files/license-3.8.diff b/dev-python/sip/files/license-3.8.diff
new file mode 100644
index 000000000000..5fba51163375
--- /dev/null
+++ b/dev-python/sip/files/license-3.8.diff
@@ -0,0 +1,34 @@
+--- build.py.orig 2003-07-30 22:07:12.000000000 +0000
++++ build.py 2003-07-30 22:07:57.000000000 +0000
+@@ -675,31 +675,6 @@
+ licType = "GPL"
+ licname = "GNU General Public License"
+
+- inform("This is the %s version of SIP and is licensed under the %s." % (licType,licname),0)
+-
+- print
+- print "Type 'L' to view the license."
+- print "Type 'yes' to accept the terms of the license."
+- print "Type 'no' to decline the terms of the license."
+- print
+-
+- while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(0)
+-
+- if resp == "l":
+- os.system("more LICENSE")
+-
+ proPatches["@BLX_SIP_LICENSE@"] = licType
+
+ inform("Building the %s version of SIP 3.7 for Python %s on %s." % (licType,pyFullVers,sys.platform))
diff --git a/dev-python/sip/sip-3.8.ebuild b/dev-python/sip/sip-3.8.ebuild
new file mode 100644
index 000000000000..69985042fca0
--- /dev/null
+++ b/dev-python/sip/sip-3.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.8.ebuild,v 1.1 2003/08/27 15:53:50 caleb Exp $
+
+IUSE=""
+
+inherit eutils distutils
+
+MY_P="${PN}-x11-gpl-${PV}"
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${MY_P}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc
+ x11-libs/qt
+ >=dev-lang/python-2.2.1"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/license-${PV}.diff
+}
+
+src_compile(){
+ distutils_python_version
+
+ chmod +x build.py
+ dodir /usr/bin
+ dodir /usr/lib/python${PYVER}/site-packages
+ python build.py -l qt-mt \
+ -b ${D}/usr/bin \
+ -d ${D}/usr/lib/python${PYVER}/site-packages \
+ -e ${D}/usr/include/python${PYVER}
+
+ make || die
+}
+
+src_install() {
+ distutils_python_version
+ dodir /usr/include/python${PYVER}
+ make DESTDIR=${D} install || die
+ dodoc NEWS README THANKS
+}