summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-16 17:15:31 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-16 17:15:31 +0000
commitae8623be345ed279850680f2c2e7d1424421bce8 (patch)
tree645039895b7e454c8f1b254b739825ff0caaef5c /dev-python
parentpatch added and deps touched (diff)
downloadgentoo-2-ae8623be345ed279850680f2c2e7d1424421bce8.tar.gz
gentoo-2-ae8623be345ed279850680f2c2e7d1424421bce8.tar.bz2
gentoo-2-ae8623be345ed279850680f2c2e7d1424421bce8.zip
version bump and housekeeping
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxPython/ChangeLog7
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.3.3.1-r21
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.4.0.61
-rw-r--r--dev-python/wxPython/wxPython-2.4.0.6.ebuild (renamed from dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild)44
4 files changed, 40 insertions, 13 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 719793aa160a..f44191bf31f5 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.20 2003/02/12 06:35:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.21 2003/03/16 17:15:31 liquidx Exp $
+
+*wxPython-2.4.0.6 (16 Mar 2003)
+
+ 16 Mar 2003; Alastair Tse <liquidx@gentoo.org> wxPython-2.4.0.6.ebuild:
+ version bump
*wxPython-2.4.0.2 (01 Feb 2003)
diff --git a/dev-python/wxPython/files/digest-wxPython-2.3.3.1-r2 b/dev-python/wxPython/files/digest-wxPython-2.3.3.1-r2
deleted file mode 100644
index d8ba57c02af6..000000000000
--- a/dev-python/wxPython/files/digest-wxPython-2.3.3.1-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ba09626f1ff92304677a473b870bcb24 wxPythonSrc-2.3.3.1.tar.gz 11143374
diff --git a/dev-python/wxPython/files/digest-wxPython-2.4.0.6 b/dev-python/wxPython/files/digest-wxPython-2.4.0.6
new file mode 100644
index 000000000000..ddc1dc09b75f
--- /dev/null
+++ b/dev-python/wxPython/files/digest-wxPython-2.4.0.6
@@ -0,0 +1 @@
+MD5 8cc3ba528fc6e3a470d6dccd251c9238 wxPythonSrc-2.4.0.6.tar.gz 12219547
diff --git a/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild b/dev-python/wxPython/wxPython-2.4.0.6.ebuild
index 1fd1b68d7435..3b4ee1fe833c 100644
--- a/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild
+++ b/dev-python/wxPython/wxPython-2.4.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.3.3.1-r2.ebuild,v 1.6 2003/02/13 11:39:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.6.ebuild,v 1.1 2003/03/16 17:15:31 liquidx Exp $
MY_P="${P/-/Src-}"
S="${WORKDIR}/${MY_P}/${PN}"
@@ -10,13 +10,13 @@ HOMEPAGE="http://www.wxpython.org/"
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="x86 ppc sparc alpha"
-IUSE="opengl"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="opengl gtk2"
DEPEND=">=dev-lang/python-2.1
- =dev-libs/glib-1.2*
- =x11-libs/gtk+-1.2*
- =x11-libs/wxGTK-2.3.3*
+ >=dev-libs/glib-1.2
+ >=x11-libs/gtk+-1.2
+ =x11-libs/wxGTK-2.4.0*
opengl? ( >=dev-python/PyOpenGL-2.0.0.44 )"
pkg_setup() {
@@ -36,18 +36,40 @@ src_compile() {
#BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
#Both these variable are enabled by default. To disable them set equal to zero
#and add to myconf.
-
local myconf=""
- if [ `use opengl` ] ; then
+ if [ `use opengl` ]; then
myconf="${myconf} BUILD_GLCANVAS=1"
else
myconf="${myconf} BUILD_GLCANVAS=0"
- patch -p1 < ${FILESDIR}/${P}-noglcanvas.diff || die "patch failed"
+ patch -p1 < ${FILESDIR}/wxPython-2.3.3.1-noglcanvas.diff \
+ || die "patch failed"
+ fi
+ if [ `use gtk2` ]; then
+ myconf="${myconf} WXPORT=gtk2"
+ else
+ myconf="${myconf} WXPORT=gtk"
fi
- python setup.py ${myconf} build || die "build failed ... make sure you compiled wxGTK with all the graphic libraries enabled via USE (jpeg png opengl gif tiff zlib gtk X)"
+ python setup.py ${myconf} build || die "build failed"
}
src_install() {
- python setup.py install --prefix=/usr --root=${D} || die
+ #Other possible configuration variables are BUILD_OGL and BUILD_STC.
+ #BUILD_OGL builds the Object Graphics Library extension module.
+ #BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
+ #Both these variable are enabled by default. To disable them set equal to zero
+ #and add to myconf.
+ local myconf=""
+ if [ `use opengl` ]; then
+ myconf="${myconf} BUILD_GLCANVAS=1"
+ else
+ myconf="${myconf} BUILD_GLCANVAS=0"
+ fi
+ if [ `use gtk2` ]; then
+ myconf="${myconf} WXPORT=gtk2"
+ else
+ myconf="${myconf} WXPORT=gtk"
+ fi
+
+ python setup.py ${myconf} install --prefix=/usr --root=${D} || die
}