summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-12-19 16:55:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-12-19 16:55:37 +0000
commit499645880124cbf7abf496fbd1cd71cf00c0bc8e (patch)
tree61c89ec26543dc2786a5004d243a5aa543d96323 /dev-python
parentAdd ~ia64, wrt bug #351931 (diff)
downloadgentoo-2-499645880124cbf7abf496fbd1cd71cf00c0bc8e.tar.gz
gentoo-2-499645880124cbf7abf496fbd1cd71cf00c0bc8e.tar.bz2
gentoo-2-499645880124cbf7abf496fbd1cd71cf00c0bc8e.zip
Keyword amd64-linux and x86-linux
(Portage version: 2.2.01.21418-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyamg/ChangeLog6
-rw-r--r--dev-python/pyamg/metadata.xml14
-rw-r--r--dev-python/pyamg/pyamg-2.0.0.ebuild57
-rw-r--r--dev-python/pyamg/pyamg-2.0.4.ebuild4
4 files changed, 15 insertions, 66 deletions
diff --git a/dev-python/pyamg/ChangeLog b/dev-python/pyamg/ChangeLog
index 46d888cb9a00..46391f7914af 100644
--- a/dev-python/pyamg/ChangeLog
+++ b/dev-python/pyamg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyamg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/ChangeLog,v 1.6 2012/08/14 16:58:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/ChangeLog,v 1.7 2012/12/19 16:55:37 bicatali Exp $
+
+ 19 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> -pyamg-2.0.0.ebuild,
+ metadata.xml, pyamg-2.0.4.ebuild:
+ Keyword amd64-linux and x86-linux
14 Aug 2012; Justin Lecher <jlec@gentoo.org> pyamg-2.0.4.ebuild,
+files/pyamg-2.0.4-gcc-4.7.patch:
diff --git a/dev-python/pyamg/metadata.xml b/dev-python/pyamg/metadata.xml
index 333d4cd38332..664651071141 100644
--- a/dev-python/pyamg/metadata.xml
+++ b/dev-python/pyamg/metadata.xml
@@ -1,8 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">AMG is a multilevel technique for solving large-scale linear systems
+<herd>sci</herd>
+<longdescription lang="en">
+ AMG is a multilevel technique for solving large-scale linear systems
with optimal or near-optimal efficiency. Unlike geometric multigrid,
AMG requires little or no geometric information about the underlying
problem and develops a sequence of coarser grids directly from the
@@ -15,8 +16,9 @@
* Adaptive Smoothed Aggregation (αSA)
* Compatible Relaxation (CR)
The predominant portion of PyAMG is written in Python with a smaller
- amount of supporting C++ code for performance critical operations.</longdescription>
- <upstream>
- <remote-id type="google-code">pyamg</remote-id>
- </upstream>
+ amount of supporting C++ code for performance critical operations.
+</longdescription>
+<upstream>
+ <remote-id type="google-code">pyamg</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/dev-python/pyamg/pyamg-2.0.0.ebuild b/dev-python/pyamg/pyamg-2.0.0.ebuild
deleted file mode 100644
index 828548713581..000000000000
--- a/dev-python/pyamg/pyamg-2.0.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/pyamg-2.0.0.ebuild,v 1.4 2012/02/23 09:58:28 patrick Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils eutils
-
-DESCRIPTION="Algebraic multigrid solvers in Python"
-HOMEPAGE="http://code.google.com/p/pyamg/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc test"
-
-RESTRICT="test" # quite buggy
-
-RDEPEND="sci-libs/scipy"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- test? ( dev-python/nose )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-stencil.patch
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- cd "${S}/Docs"
- PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) emake html
- fi
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py \
- build -b "build-${PYTHON_ABI}" \
- install --home="${S}/test-${PYTHON_ABI}"
- pushd "${S}/test-${PYTHON_ABI}/lib/python" > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import pyamg; pyamg.test()" 2>&1 | tee test.log
- grep -Eq "^(ERROR|FAIL):" test.log && return 1
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r Docs/build/html/*
-}
diff --git a/dev-python/pyamg/pyamg-2.0.4.ebuild b/dev-python/pyamg/pyamg-2.0.4.ebuild
index a8f930b6feb3..1d201505745d 100644
--- a/dev-python/pyamg/pyamg-2.0.4.ebuild
+++ b/dev-python/pyamg/pyamg-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/pyamg-2.0.4.ebuild,v 1.2 2012/08/14 16:58:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/pyamg-2.0.4.ebuild,v 1.3 2012/12/19 16:55:37 bicatali Exp $
EAPI=4
@@ -16,7 +16,7 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
RESTRICT="test" # quite buggy