summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-02 00:33:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-02 00:33:05 +0000
commit78cd0d6904f4440b806d0912ab01394894d6feba (patch)
tree8def6c2d8b7711473e2a67bb5c84079fe16d6e6a /dev-ruby/activesupport
parentMinor fix (diff)
downloadgentoo-2-78cd0d6904f4440b806d0912ab01394894d6feba.tar.gz
gentoo-2-78cd0d6904f4440b806d0912ab01394894d6feba.tar.bz2
gentoo-2-78cd0d6904f4440b806d0912ab01394894d6feba.zip
Version bump unbundling i18n; unfortunately the deptree is no longer jruby compatible (for now).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog11
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild29
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index b42bf1788bb1..7e69cf4eea29 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activesupport
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.113 2009/12/21 00:10:42 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.114 2010/01/02 00:33:05 flameeyes Exp $
+
+*activesupport-2.3.5-r2 (02 Jan 2010)
+
+ 02 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +activesupport-2.3.5-r2.ebuild:
+ Version bump unbundling i18n; unfortunately the deptree is no longer jruby
+ compatible (for now).
21 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
activesupport-2.3.5-r1.ebuild:
diff --git a/dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild b/dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild
new file mode 100644
index 000000000000..be6f9e42151b
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild,v 1.1 2010/01/02 00:33:05 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.12 dev-ruby/i18n"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+}