summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-18 19:04:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-18 19:04:50 +0000
commit7b9852f71fe221a25ce762cd3a874cf6763629a0 (patch)
treec9ea63778b28eb0e4265bc3651a0c32950b3f7b3 /dev-ruby/activesupport
parentalpha/ia64/sh/sparc stable wrt #294958 (diff)
downloadgentoo-2-7b9852f71fe221a25ce762cd3a874cf6763629a0.tar.gz
gentoo-2-7b9852f71fe221a25ce762cd3a874cf6763629a0.tar.bz2
gentoo-2-7b9852f71fe221a25ce762cd3a874cf6763629a0.zip
Bump revision to properly fix support to use the unbundled i18n gem (with the proper slot).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog10
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild (renamed from dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild)9
-rw-r--r--dev-ruby/activesupport/files/activesupport-2.3.5-unvendorize.patch35
3 files changed, 51 insertions, 3 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 2a20b9e037a6..31d441da6d7f 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.115 2010/01/04 10:50:11 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.116 2010/01/18 19:04:49 flameeyes Exp $
+
+*activesupport-2.3.5-r3 (18 Jan 2010)
+
+ 18 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -activesupport-2.3.5-r2.ebuild, +activesupport-2.3.5-r3.ebuild,
+ +files/activesupport-2.3.5-unvendorize.patch:
+ Bump revision to properly fix support to use the unbundled i18n gem (with
+ the proper slot).
04 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
activesupport-2.3.5-r2.ebuild:
diff --git a/dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild b/dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild
index 320cb22156f7..a116a868e9ac 100644
--- a/dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild
+++ b/dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5-r2.ebuild,v 1.2 2010/01/04 10:50:11 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild,v 1.1 2010/01/18 19:04:49 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18"
@@ -20,10 +20,15 @@ SLOT="2.3"
KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""
-ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.12 dev-ruby/i18n"
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.12 >=dev-ruby/i18n-0.1.3:0.1"
all_ruby_prepare() {
# Remove the bundled packages!
rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
|| die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use only the 0.1
+ # slot.
+ epatch "${FILESDIR}"/${P}-unvendorize.patch
}
diff --git a/dev-ruby/activesupport/files/activesupport-2.3.5-unvendorize.patch b/dev-ruby/activesupport/files/activesupport-2.3.5-unvendorize.patch
new file mode 100644
index 000000000000..c2df9e426e78
--- /dev/null
+++ b/dev-ruby/activesupport/files/activesupport-2.3.5-unvendorize.patch
@@ -0,0 +1,35 @@
+Index: activesupport-2.3.5/lib/active_support/vendor.rb
+===================================================================
+--- activesupport-2.3.5.orig/lib/active_support/vendor.rb
++++ activesupport-2.3.5/lib/active_support/vendor.rb
+@@ -1,11 +1,7 @@
+ # Prefer gems to the bundled libs.
+ require 'rubygems'
+
+-begin
+- gem 'builder', '~> 2.1.2'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/builder-2.1.2"
+-end
++gem 'builder', '~> 2.1.2'
+ require 'builder'
+
+ begin
+@@ -14,15 +10,7 @@ rescue Gem::LoadError
+ $:.unshift "#{File.dirname(__FILE__)}/vendor/memcache-client-1.7.4"
+ end
+
+-begin
+- gem 'tzinfo', '~> 0.3.12'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/tzinfo-0.3.12"
+-end
++gem 'tzinfo', '~> 0.3.12'
+
+-begin
+- gem 'i18n', '>= 0.1.3'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/i18n-0.1.3/lib"
+-end
++gem 'i18n', '~> 0.1.3'
+ require 'i18n'