summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-08-25 07:48:14 +0000
committerHans de Graaff <graaff@gentoo.org>2013-08-25 07:48:14 +0000
commit17b713e6e9d766bd37638af68cf30d80fc7b95d2 (patch)
tree790e1b1f26de593a5fc717d817c9c1a595d84545 /dev-ruby/multi_json
parentdev-haskell/byteorder: 1.0.4 layout (diff)
downloadgentoo-2-17b713e6e9d766bd37638af68cf30d80fc7b95d2.tar.gz
gentoo-2-17b713e6e9d766bd37638af68cf30d80fc7b95d2.tar.bz2
gentoo-2-17b713e6e9d766bd37638af68cf30d80fc7b95d2.zip
Cleanup. There is no need to keep old versions around since multi_json adheres to semantic versioning.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog6
-rw-r--r--dev-ruby/multi_json/multi_json-1.0.4.ebuild47
2 files changed, 5 insertions, 48 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 2024a0b99cd4..20de127b0b4e 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.31 2013/08/23 22:44:24 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.32 2013/08/25 07:48:14 graaff Exp $
+
+ 25 Aug 2013; Hans de Graaff <graaff@gentoo.org> -multi_json-1.0.4.ebuild:
+ Cleanup. There is no need to keep old versions around since multi_json
+ adheres to semantic versioning.
*multi_json-1.0.4 (23 Aug 2013)
diff --git a/dev-ruby/multi_json/multi_json-1.0.4.ebuild b/dev-ruby/multi_json/multi_json-1.0.4.ebuild
deleted file mode 100644
index dab946910fec..000000000000
--- a/dev-ruby/multi_json/multi_json-1.0.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.0.4.ebuild,v 1.10 2013/08/23 22:44:24 zerochaos Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
-
-USE_RUBY=ruby18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ruby19 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ree18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Remove simplecov support since we only care about the test results
- # and this avoids another dependency.
- sed -i -e '/[Ss]imple[Cc]ov/d' spec/helper.rb || die
-
- # Provide version otherwise provided by bundler.
- sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
-}