summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-01-17 07:07:49 +0000
committerHans de Graaff <graaff@gentoo.org>2014-01-17 07:07:49 +0000
commit5f22f020478097f4121fe684f5a6f3d76c39adbe (patch)
treed047040aa88fa617d41c824bb3cc561b542f697e /dev-ruby/omniauth
parentupdate maintainer email (diff)
downloadgentoo-2-5f22f020478097f4121fe684f5a6f3d76c39adbe.tar.gz
gentoo-2-5f22f020478097f4121fe684f5a6f3d76c39adbe.tar.bz2
gentoo-2-5f22f020478097f4121fe684f5a6f3d76c39adbe.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/omniauth')
-rw-r--r--dev-ruby/omniauth/ChangeLog9
-rw-r--r--dev-ruby/omniauth/omniauth-1.2.1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-ruby/omniauth/ChangeLog b/dev-ruby/omniauth/ChangeLog
index e08225c6c6f4..340aee1c6e4c 100644
--- a/dev-ruby/omniauth/ChangeLog
+++ b/dev-ruby/omniauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/omniauth
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/omniauth/ChangeLog,v 1.3 2013/11/22 05:21:53 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/omniauth/ChangeLog,v 1.4 2014/01/17 07:07:49 graaff Exp $
+
+*omniauth-1.2.1 (17 Jan 2014)
+
+ 17 Jan 2014; Hans de Graaff <graaff@gentoo.org> +omniauth-1.2.1.ebuild:
+ Version bump.
22 Nov 2013; Patrick Lauer <patrick@gentoo.org> omniauth-1.1.4-r1.ebuild:
Whitespace
diff --git a/dev-ruby/omniauth/omniauth-1.2.1.ebuild b/dev-ruby/omniauth/omniauth-1.2.1.ebuild
new file mode 100644
index 000000000000..39fea65ee5f2
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/omniauth/omniauth-1.2.1.ebuild,v 1.1 2014/01/17 07:07:49 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack dev-ruby/hashie"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}