summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-04-23 13:28:34 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-04-23 13:28:34 +0000
commit497cb13db13cac5d46a442a6374797bf7b04ee21 (patch)
tree89e68eea0c732f0dceb130198d1b4fdd33ac4ff6 /dev-ruby
parentVersion bump, currently masked (diff)
downloadgentoo-2-497cb13db13cac5d46a442a6374797bf7b04ee21.tar.gz
gentoo-2-497cb13db13cac5d46a442a6374797bf7b04ee21.tar.bz2
gentoo-2-497cb13db13cac5d46a442a6374797bf7b04ee21.zip
version bump for new IceRuby, currently package.masked
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/IceRuby/ChangeLog10
-rw-r--r--dev-ruby/IceRuby/IceRuby-3.3.0_beta1.ebuild62
-rw-r--r--dev-ruby/IceRuby/files/IceRuby-3.3.0_beta1-Makefile.patch93
3 files changed, 163 insertions, 2 deletions
diff --git a/dev-ruby/IceRuby/ChangeLog b/dev-ruby/IceRuby/ChangeLog
index 8bc3b5a25caf..3c9cf9b1226a 100644
--- a/dev-ruby/IceRuby/ChangeLog
+++ b/dev-ruby/IceRuby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/IceRuby
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/ChangeLog,v 1.12 2007/09/26 06:26:23 opfer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/ChangeLog,v 1.13 2008/04/23 13:28:33 caleb Exp $
+
+*IceRuby-3.3.0_beta1 (23 Apr 2008)
+
+ 23 Apr 2008; Caleb Tennis <caleb@gentoo.org>
+ +files/IceRuby-3.3.0_beta1-Makefile.patch, +IceRuby-3.3.0_beta1.ebuild:
+ version bump for new ice, currently package.masked
26 Sep 2007; Christian Faulhammer <opfer@gentoo.org>
IceRuby-3.2.1-r1.ebuild:
diff --git a/dev-ruby/IceRuby/IceRuby-3.3.0_beta1.ebuild b/dev-ruby/IceRuby/IceRuby-3.3.0_beta1.ebuild
new file mode 100644
index 000000000000..e2f15b4e9e23
--- /dev/null
+++ b/dev-ruby/IceRuby/IceRuby-3.3.0_beta1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/IceRuby-3.3.0_beta1.ebuild,v 1.1 2008/04/23 13:28:33 caleb Exp $
+
+inherit eutils
+
+MY_P=${P/Ruby/}
+MY_P=${MY_P/3.3.0_beta1/3.3b}
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.3/${MY_P}.tar.gz"
+
+S=${WORKDIR}/${MY_P}/rb
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test debug"
+
+RDEPEND="~dev-cpp/Ice-3.3.0_beta1
+ >=dev-lang/ruby-1.8.6"
+
+DEPEND="${RDEPEND}
+ test? ( >=dev-lang/python-2.4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+
+ MAKE_RULES="${S}/config/Make.rules"
+
+ mkdir -p "${S}/bin"
+ mkdir -p "${S}/lib"
+
+ cp /usr/bin/slice2rb "${S}"/../cpp/bin
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" "${MAKE_RULES}" \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ "${MAKE_RULES}" || die "Failed to remove debug"
+ fi
+
+# sed -i -e \
+# "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+# "${MAKE_RULES}.Linux" || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ make depend
+ emake || die "Died during make"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install Failed!"
+}
diff --git a/dev-ruby/IceRuby/files/IceRuby-3.3.0_beta1-Makefile.patch b/dev-ruby/IceRuby/files/IceRuby-3.3.0_beta1-Makefile.patch
new file mode 100644
index 000000000000..a294395f1f57
--- /dev/null
+++ b/dev-ruby/IceRuby/files/IceRuby-3.3.0_beta1-Makefile.patch
@@ -0,0 +1,93 @@
+--- ruby/Makefile.orig 2007-03-13 08:31:21.000000000 -0400
++++ ruby/Makefile 2007-03-13 08:31:50.000000000 -0400
+@@ -128,8 +128,8 @@
+ @echo "Installing generated code"
+ @for i in $(MODULES) ; \
+ do \
+- $(INSTALL_DATA) $${i}.rb $(install_rubydir) ; \
+- $(INSTALL_DATA) -r $$i $(install_rubydir) ; \
++ $(INSTALL_DATA) $${i}.rb $(install_rubylibdir) ; \
++ $(INSTALL_DATA) -r $$i $(install_rubylibdir) ; \
+ done
+
+ clean::
+--- src/IceRuby/Makefile.orig 2007-03-13 08:31:58.000000000 -0400
++++ src/IceRuby/Makefile 2007-03-13 08:35:59.000000000 -0400
+@@ -48,6 +48,6 @@
+ ln -s $(SONAME) $@
+
+ install:: all
+- $(call installlib,$(install_libdir),$(libdir),$(LIBFILENAME),$(SONAME),$(LIBNAME))
++ $(call installlib,$(install_rubyarchdir),$(libdir),$(LIBFILENAME),$(SONAME),$(LIBNAME))
+
+ include .depend
+--- config/Make.rules.orig 2008-04-02 13:13:25.000000000 -0400
++++ config/Make.rules 2008-04-02 13:15:14.000000000 -0400
+@@ -12,13 +12,13 @@
+ # if it does not exist.
+ #
+
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= $(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with optimization.
+@@ -45,8 +45,10 @@
+ RUBY = ruby
+ endif
+
+-RUBY_INCLUDE_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
+-RUBY_LIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(libdir)")')
++RUBY_ARCH_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
++RUBY_LIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(rubylibdir)")')
++RUBY_SITEARCH_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitearchdir)")')
++RUBY_SITELIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitelibdir)")')
+
+ RUBY_SHARED = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::MAKEFILE_CONFIG["ENABLE_SHARED"]')
+
+@@ -56,7 +58,7 @@
+ RUBY_LIB = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("-l$$(RUBY_SO_NAME)-static")')
+ endif
+
+-RUBY_FLAGS = -I$(RUBY_INCLUDE_DIR)
++RUBY_FLAGS = -I$(RUBY_ARCH_DIR)
+ RUBY_LIBS = -L$(RUBY_LIB_DIR) $(RUBY_LIB)
+
+ # ----------------------------------------------------------------------
+@@ -77,8 +79,8 @@
+ endif
+
+ libdir = $(top_srcdir)/ruby
+-install_rubydir = $(prefix)/ruby
+-install_libdir = $(prefix)/ruby
++install_rubylibdir = $(DESTDIR)/$(RUBY_SITELIB_DIR)
++install_rubyarchdir = $(DESTDIR)/$(RUBY_SITELIB_DIR)
+
+ #
+ # Platform specific definitions
+--- Makefile.orig 2008-04-23 09:17:07.000000000 -0400
++++ Makefile 2008-04-23 09:17:27.000000000 -0400
+@@ -13,11 +13,11 @@
+
+ SUBDIRS = src ruby
+
+-install:: install-common
+- @if test ! -d $(install_rubydir) ; \
++install::
++ @if test ! -d $(install_rubylibdir) ; \
+ then \
+- echo "Creating $(install_rubydir)..." ; \
+- $(call mkdir,$(install_rubydir)) ; \
++ echo "Creating $(install_rubylibdir)..." ; \
++ mkdir -p $(install_rubylibdir) ; \
+ fi
+
+ $(EVERYTHING)::
+