summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Cunha <tcunha@gentoo.org>2008-11-20 02:49:27 +0000
committerTiago Cunha <tcunha@gentoo.org>2008-11-20 02:49:27 +0000
commit16db6090f66e85e902072ab9fa3697a32837b9e0 (patch)
tree8b8f87a936787d9325b9b68660486f12f621ec0c /dev-util/cutils
parentFix whitespace. (diff)
downloadgentoo-2-16db6090f66e85e902072ab9fa3697a32837b9e0.tar.gz
gentoo-2-16db6090f66e85e902072ab9fa3697a32837b9e0.tar.bz2
gentoo-2-16db6090f66e85e902072ab9fa3697a32837b9e0.zip
Revision bump:
- Remove unneeded (R)DEPEND. - Use econf instead of configure. - Use emake instead of make in src_install. - Use die messages to ease error identification. - Don't dodoc COPYRIGHT, and INSTALL. (Portage version: 2.1.4.5)
Diffstat (limited to 'dev-util/cutils')
-rw-r--r--dev-util/cutils/ChangeLog12
-rw-r--r--dev-util/cutils/cutils-1.6-r3.ebuild40
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-util/cutils/ChangeLog b/dev-util/cutils/ChangeLog
index 747f04133a7c..b50124e788b0 100644
--- a/dev-util/cutils/ChangeLog
+++ b/dev-util/cutils/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-util/cutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cutils/ChangeLog,v 1.23 2008/11/20 01:51:30 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cutils/ChangeLog,v 1.24 2008/11/20 02:49:27 tcunha Exp $
+
+*cutils-1.6-r3 (20 Nov 2008)
+
+ 20 Nov 2008; Tiago Cunha <tcunha@gentoo.org> +cutils-1.6-r3.ebuild:
+ Revision bump:
+ - Remove unneeded (R)DEPEND.
+ - Use econf instead of configure.
+ - Use emake instead of make in src_install.
+ - Use die messages to ease error identification.
+ - Don't dodoc COPYRIGHT, and INSTALL.
20 Nov 2008; Tiago Cunha <tcunha@gentoo.org>
-files/cutils-1.6-gentoo.diff:
diff --git a/dev-util/cutils/cutils-1.6-r3.ebuild b/dev-util/cutils/cutils-1.6-r3.ebuild
new file mode 100644
index 000000000000..c6d756ecc325
--- /dev/null
+++ b/dev-util/cutils/cutils-1.6-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cutils/cutils-1.6-r3.ebuild,v 1.1 2008/11/20 02:49:27 tcunha Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="C language utilities"
+HOMEPAGE="http://www.sigala.it/sandro/software.php#cutils"
+SRC_URI="http://www.sigala.it/sandro/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-r1-gentoo.diff
+ cd "${S}"/src/cdecl
+ mv cdecl.1 cutils-cdecl.1
+ for file in "${S}"/doc/*; do
+ sed -e 's/cdecl/cutils-cdecl/g' -i "${file}"
+ done
+ sed -e 's/Xr cdecl/Xr cutils-cdecl/' -i "${S}"/src/cundecl/cundecl.1
+}
+
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)" -j1 || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CREDITS HISTORY NEWS README || die "dodoc failed"
+}
+
+pkg_postinst () {
+ elog "cdecl was installed as cutils-cdecl because of a naming conflict"
+ elog "with dev-util/cdecl."
+}