summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Silva <r3pek@gentoo.org>2005-05-05 14:26:48 +0000
committerCarlos Silva <r3pek@gentoo.org>2005-05-05 14:26:48 +0000
commit3144ea6f91678b3728e47ad0642f3c0a20faea9e (patch)
treec5ec34628a90c82a09a22e38c7cdddc80aa05c40 /dev-util/git
parent+>=net-nntp/leafnode-2.0.0_alpha0 (diff)
downloadgentoo-2-3144ea6f91678b3728e47ad0642f3c0a20faea9e.tar.gz
gentoo-2-3144ea6f91678b3728e47ad0642f3c0a20faea9e.tar.bz2
gentoo-2-3144ea6f91678b3728e47ad0642f3c0a20faea9e.zip
Removing old git version (0.6) and adding the new one (0.7)
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/files/digest-git-0.61
-rw-r--r--dev-util/git/files/digest-git-0.71
-rw-r--r--dev-util/git/git-0.6.ebuild30
-rw-r--r--dev-util/git/git-0.7.ebuild48
5 files changed, 56 insertions, 32 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index c21e1978864e..92ad9f2198ab 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.4 2005/04/25 23:44:19 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.5 2005/05/05 14:26:48 r3pek Exp $
+
+*git-0.7 (05 May 2005)
+
+ 05 May 2005; Carlos Silva <r3pek@gentoo.org> -git-0.6.ebuild,
+ +git-0.7.ebuild:
+ Removing old git version (0.6) and adding the new one (0.7)
*git-0.6 (26 Apr 2005)
diff --git a/dev-util/git/files/digest-git-0.6 b/dev-util/git/files/digest-git-0.6
deleted file mode 100644
index 5e2fc2f29d66..000000000000
--- a/dev-util/git/files/digest-git-0.6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3829867124c121255a72e6ea415e834f git-0.6.tar.bz2 38657
diff --git a/dev-util/git/files/digest-git-0.7 b/dev-util/git/files/digest-git-0.7
new file mode 100644
index 000000000000..2d748b2d2507
--- /dev/null
+++ b/dev-util/git/files/digest-git-0.7
@@ -0,0 +1 @@
+MD5 036e3a031d03d1cb4ac4cbe16cca141b git-0.7.tar.bz2 52108
diff --git a/dev-util/git/git-0.6.ebuild b/dev-util/git/git-0.6.ebuild
deleted file mode 100644
index 61f4e41f756e..000000000000
--- a/dev-util/git/git-0.6.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-0.6.ebuild,v 1.3 2005/04/29 13:36:22 r3pek Exp $
-
-DESCRIPTION="GIT - the stupid content tracker"
-HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/torvalds/"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/people/torvalds/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-DEPEND="dev-libs/openssl
- sys-libs/zlib
- !dev-util/git-pasky
- !dev-util/cogito"
-
-src_compile() {
- emake CFLAGS="${CFLAGS}" || die "make failed"
-}
-
-src_install() {
- dobin cat-file checkout-cache commit-tree diff-tree fsck-cache init-db \
- read-tree show-diff update-cache write-tree check-files \
- convert-cache diff-cache git-export git-merge-one-file-script \
- git-prune-script git-pull-script ls-tree merge-base merge-cache \
- rev-tree show-files unpack-file || die "dobin failed"
- dodoc README || die "dodoc failed"
-}
diff --git a/dev-util/git/git-0.7.ebuild b/dev-util/git/git-0.7.ebuild
new file mode 100644
index 000000000000..679bcfbd0c47
--- /dev/null
+++ b/dev-util/git/git-0.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-0.7.ebuild,v 1.1 2005/05/05 14:26:48 r3pek Exp $
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="http://kernel.org/pub/software/scm/git/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="mozsha1 ppcsha1"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !dev-util/git-pasky
+ !dev-util/cogito"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:-g -O2:${CFLAGS}:" \
+ Makefile
+}
+
+src_compile() {
+ if use mozsha1; then
+ export MOZILLA_SHA1=yes
+ elif use ppcsha1; then
+ export PPC_SHA1=yes
+ fi
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin git-cat-file git-check-files git-checkout-cache git-commit-tree \
+ git-convert-cache git-diff-cache git-diff-files git-diff-tree \
+ git-diff-tree-helper git-export git-fsck-cache git-http-pull \
+ git-init-db git-ls-tree git-merge-base git-merge-cache git-mktag \
+ git-prune-script git-pull-script git-read-tree git-rev-list \
+ git-rev-tree git-rpull git-rpush git-show-files git-tag-script \
+ git-tar-tree git-unpack-file git-update-cache git-write-tree \
+ git-merge-one-file-script
+
+ dodoc README || die "dodoc failed"
+}