summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-22 01:31:10 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-22 01:31:10 +0000
commit57133842a679a5bb534da566d32e0dd50a5fcab5 (patch)
treed18f65e449755d37b0452fe98c92287d1f82f1da /dev-util/sun-one-studio-me/sun-one-studio-me-4.1.ebuild
parentamd64 (Manifest recommit) (diff)
downloadgentoo-2-57133842a679a5bb534da566d32e0dd50a5fcab5.tar.gz
gentoo-2-57133842a679a5bb534da566d32e0dd50a5fcab5.tar.bz2
gentoo-2-57133842a679a5bb534da566d32e0dd50a5fcab5.zip
Initial Import.
Diffstat (limited to 'dev-util/sun-one-studio-me/sun-one-studio-me-4.1.ebuild')
-rw-r--r--dev-util/sun-one-studio-me/sun-one-studio-me-4.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/sun-one-studio-me/sun-one-studio-me-4.1.ebuild b/dev-util/sun-one-studio-me/sun-one-studio-me-4.1.ebuild
new file mode 100644
index 000000000000..62ad6a40fea7
--- /dev/null
+++ b/dev-util/sun-one-studio-me/sun-one-studio-me-4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sun-one-studio-me/sun-one-studio-me-4.1.ebuild,v 1.1 2004/02/22 01:31:10 zx Exp $
+
+DESCRIPTION="Sun ONE Studio Mobile Edition"
+HOMEPAGE="http://wwws.sun.com/software/sundev/jde/studio_me/index.html"
+SRC_URI="ffj_me_linux.bin"
+LICENSE="sun-bcla-sos"
+SLOT="0"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4.1"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from ${HOMEPAGE} and move it to ${DISTDIR}"
+}
+
+
+src_unpack() {
+ unzip -q ${DISTDIR}/${SRC_URI} -d ${S}
+}
+
+src_install() {
+ addwrite "/var/lib/rpm/__db.Name."
+ addwrite "/var/lib/rpm/Name"
+ ${JAVA_HOME}/bin/java -DjdkHome=`java-config --jdk-home` -DforteHome="${D}/opt/s1studiome/" run -silent
+}