summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2004-02-13 19:55:21 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2004-02-13 19:55:21 +0000
commit71e71d200213bf5ec6d12e1a2514290ed3bec933 (patch)
tree412534798dc4bae35c7d141313c8659634f352d4 /dev-util
parentstable happy (diff)
downloadgentoo-2-71e71d200213bf5ec6d12e1a2514290ed3bec933.tar.gz
gentoo-2-71e71d200213bf5ec6d12e1a2514290ed3bec933.tar.bz2
gentoo-2-71e71d200213bf5ec6d12e1a2514290ed3bec933.zip
various fixes
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/subversion/ChangeLog11
-rw-r--r--dev-util/subversion/subversion-0.37.0.ebuild17
2 files changed, 20 insertions, 8 deletions
diff --git a/dev-util/subversion/ChangeLog b/dev-util/subversion/ChangeLog
index cddb788e9d29..4f37c3686fb5 100644
--- a/dev-util/subversion/ChangeLog
+++ b/dev-util/subversion/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/subversion
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.50 2004/02/11 10:05:57 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.51 2004/02/13 19:55:21 pauldv Exp $
+
+ 13 Feb 2004; <paul@gentoo.org> subversion-0.37.0.ebuild:
+ Make emacs regeneration more tolerant (bug #41411)
11 Feb 2004; Paul de Vrieze <pauldv@gentoo.org> subversion-0.37.0.ebuild:
Add optional emacs dependency
@@ -8,10 +11,16 @@
05 Feb 2004; Paul de Vrieze <pauldv@gentoo.org> subversion-0.37.0.ebuild:
Some autoconf changes
+ 04 Feb 2004; <paul@gentoo.org> subversion-0.37.0.ebuild:
+ Some more explanations
+
04 Feb 2004; Paul de Vrieze <pauldv@gentoo.org> subversion-0.37.0.ebuild:
Take the new FHS's /srv directory into account, moving the default location
from /var
+ 03 Feb 2004; <paul@gentoo.org> subversion-0.37.0.ebuild:
+ Hopefully fix emacs module compilation problems
+
*subversion-0.37.0 (28 Jan 2004)
28 Jan 2004; Paul de Vrieze <pauldv@gentoo.org> subversion-0.37.0.ebuild:
diff --git a/dev-util/subversion/subversion-0.37.0.ebuild b/dev-util/subversion/subversion-0.37.0.ebuild
index 343d3c69a625..7072b97cac4f 100644
--- a/dev-util/subversion/subversion-0.37.0.ebuild
+++ b/dev-util/subversion/subversion-0.37.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.37.0.ebuild,v 1.6 2004/02/11 10:05:57 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.37.0.ebuild,v 1.7 2004/02/13 19:55:21 pauldv Exp $
inherit elisp-common libtool
@@ -44,7 +44,7 @@ DEPEND="${RDEPEND}
)"
pkg_setup() {
- if has_version '<dev-util/subversion-0.34.0' && [ "${SVN_DUMPED}" == "" ]; then
+ if use berkdb && has_version '<dev-util/subversion-0.34.0' && [ "${SVN_DUMPED}" == "" ]; then
einfo ""
ewarn ": Now you have $(best_version subversion)"
ewarn " Subversion has changed the repository filesystem schema from 0.34.0."
@@ -59,12 +59,13 @@ pkg_setup() {
if use apache2; then
einfo "The apache2 subversion module will be built, and libapr from the"
- einfo "apache package will be used instead of the included"
+ einfo "apache package will be used instead of the included."
else
einfo "Please note that subversion and apache2 cannot be installed"
einfo "simultaneously without specifying the apache2 use flag. This is"
einfo "because subversion installs its own libapr and libapr-util in that"
- einfo "case."
+ einfo "case. Specifying the apache2 useflag will also enable the building of"
+ einfo "the apache2 module."
fi
}
@@ -126,9 +127,11 @@ src_compile() {
fi
fi
fi
+ cd ${S}
if use emacs; then
- emacs -batch -f batch-byte-compile contrib/client-side/vc-svn.el || die
- emacs -batch -f batch-byte-compile contrib/client-side/psvn/psvn.el || die
+ einfo "compiling emacs support"
+ elisp-compile ${S}/contrib/client-side/psvn/psvn.el || die "emacs modules failed"
+ elisp-compile ${S}/contrib/client-side/vc-svn.el || die "emacs modules failed"
fi
}
@@ -239,7 +242,7 @@ pkg_postinst() {
}
pkg_postrm() {
- use emacs && elisp-site-regen
+ has_version virtual/emacs && elisp-site-regen
}
pkg_config() {