summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-05-25 16:27:06 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-05-25 16:27:06 +0000
commit2f623e31382732a62a0c223a2af0d69ae8733af7 (patch)
tree5dd7c37ed3d04ccb0619cc6e9862a5f6889e734f /eclass/kde.eclass
parent0.2.1-r1 stable on x86 and amd64, some cleanup (diff)
downloadgentoo-2-2f623e31382732a62a0c223a2af0d69ae8733af7.tar.gz
gentoo-2-2f623e31382732a62a0c223a2af0d69ae8733af7.tar.bz2
gentoo-2-2f623e31382732a62a0c223a2af0d69ae8733af7.zip
Applied patch to disable visibility support in KDE 3.4, closes bug 86898.
Diffstat (limited to 'eclass/kde.eclass')
-rw-r--r--eclass/kde.eclass16
1 files changed, 7 insertions, 9 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index dfabfb34cace..49f1ff2368a9 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.117 2005/05/17 13:45:12 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.118 2005/05/25 16:26:40 cryos Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -63,14 +63,12 @@ kde_src_unpack() {
touch $UIFILES
fi
- # temp fix for bug #78720, until the real bug in gcc gets fixed
- # briefly, -fvisibility-inlines-hidden is broken on amd64 and ppc
- # this only applies to kde 3.4. the grep prevents us from removing configure unnecessarily.
- if useq amd64 || useq ppc; then
- if grep -qs -- '-fvisibility=hidden -fvisibility-inlines-hidden' admin/acinclude.m4.in ; then
- sed -i -e 's:-fvisibility=hidden -fvisibility-inlines-hidden:-fvisibility=hidden:' admin/acinclude.m4.in
- rm -f configure
- fi
+ # Visibility support is broken in KDE. Disable it when present until
+ # upstream finds a way to get it working properly. Bug 86898.
+ if grep HAVE_GCC_VISIBILITY configure &> /dev/null || ! [[ -f configure ]]; then
+ find ${S} -name configure.in.in | xargs sed -i -e \
+ 's:KDE_ENABLE_HIDDEN_VISIBILITY::g'
+ rm -f configure
fi
}