summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-15 05:10:47 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-15 05:10:47 +0000
commit0e48768f5861d68807bfa0ab0161d271c892769c (patch)
tree5cb309c4ed69c219612bc87b59f59f84533ee9af /eclass
parentbump; update deps, add fix to qa issue in the build, correction to test phase (diff)
downloadgentoo-2-0e48768f5861d68807bfa0ab0161d271c892769c.tar.gz
gentoo-2-0e48768f5861d68807bfa0ab0161d271c892769c.tar.bz2
gentoo-2-0e48768f5861d68807bfa0ab0161d271c892769c.zip
eautoconf: dump a QA warning when we find old configure.in files instead of configure.ac #426262
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass7
1 files changed, 6 insertions, 1 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index d7fa44684ff5..8271aad01267 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.165 2014/11/14 01:31:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.166 2014/11/15 05:10:47 vapier Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -330,6 +330,11 @@ eautoconf() {
echo
die "No configure.{ac,in} present!"
fi
+ if [[ -e configure.in ]] ; then
+ eqawarn "This package has a configure.in file which has long been deprecated. Please"
+ eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
+ eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ fi
autotools_run_tool --at-m4flags autoconf "$@"
}