summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commitf199057b8679cd2eed424fccb45361c89a133d31 (patch)
treee6ec41e59db82809cd99452c53c9efe67a3985e3 /games-action/xpilot
parentgames action and arcade (diff)
downloadgentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.gz
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.bz2
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.zip
action games !
Diffstat (limited to 'games-action/xpilot')
-rw-r--r--games-action/xpilot/ChangeLog26
-rw-r--r--games-action/xpilot/Manifest3
-rw-r--r--games-action/xpilot/files/digest-xpilot-4.5.41
-rw-r--r--games-action/xpilot/xpilot-4.5.4.ebuild40
4 files changed, 70 insertions, 0 deletions
diff --git a/games-action/xpilot/ChangeLog b/games-action/xpilot/ChangeLog
new file mode 100644
index 000000000000..66b8e6655824
--- /dev/null
+++ b/games-action/xpilot/ChangeLog
@@ -0,0 +1,26 @@
+# ChangeLog for app-games/xpilot
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+ 17 Jun 2003; msterret xpilot-4.5.4.ebuild:
+ use sed -i and emake
+
+*xpilot-4.5.4 (15 Dec 2002)
+
+ 15 Dec 2002; Maik Schreiber <blizzy@gentoo.org> : New version.
+
+ 30 Nov 2002; Jon Nall <nall@gentoo.org> xpilot-4.5.3.ebuild:
+ keyworded as ~ppc
+
+ 17 Jul 2002; Jose Alberto Suárez López <bass@gentoo.org> xpilot-4.5.3.ebuild:
+ Added KEYWORDS.
+
+*xpilot-4.5.3 (21 Jun 2002)
+
+ 21 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog:
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/games-action/xpilot/Manifest b/games-action/xpilot/Manifest
new file mode 100644
index 000000000000..74c08ba2ddce
--- /dev/null
+++ b/games-action/xpilot/Manifest
@@ -0,0 +1,3 @@
+MD5 1960a0cd31654a78835dc212b82037af ChangeLog 1031
+MD5 737b294ce60841f44f9875873eeb3c32 xpilot-4.5.4.ebuild 1179
+MD5 58cf426f1a9fb576293c73a6edc8db61 files/digest-xpilot-4.5.4 65
diff --git a/games-action/xpilot/files/digest-xpilot-4.5.4 b/games-action/xpilot/files/digest-xpilot-4.5.4
new file mode 100644
index 000000000000..7fb20debe6b9
--- /dev/null
+++ b/games-action/xpilot/files/digest-xpilot-4.5.4
@@ -0,0 +1 @@
+MD5 f2774fda5938629001ed65a311554c01 xpilot-4.5.4.tar.gz 1384615
diff --git a/games-action/xpilot/xpilot-4.5.4.ebuild b/games-action/xpilot/xpilot-4.5.4.ebuild
new file mode 100644
index 000000000000..b99973266eae
--- /dev/null
+++ b/games-action/xpilot/xpilot-4.5.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.4.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+DESCRIPTION="A multi-player 2D client/server space game"
+HOMEPAGE="http://www.xpilot.org/"
+SRC_URI="http://xpilot.org/pub/xpilot/${P}.tar.gz"
+
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="x11-base/xfree
+ >=sys-apps/sed-4"
+
+src_compile() {
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ -e "s:/man/man:/share/man/man:" \
+ Local.config || die "sed Local.config failed"
+
+ # the stuff xpilot puts it /usr/lib should go
+ # in /usr/share , but I'm leaving it for now.
+
+ xmkmf || die "xmkmf Makefile creation failed"
+ make Makefiles || die "Makefiles problem"
+ local f
+ for f in `find . -type f -regex .*Makefile`; do
+ sed -i -e "s:CDEBUGFLAGS = -O:CDEBUGFLAGS = ${CFLAGS}:" $f ||
+ die "sed $f failed"
+ done
+ make includes || die "includes problem"
+ make depend || die "depend problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install problem"
+ make DESTDIR=${D} install.man || die "install.man problem"
+}