summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-12 20:38:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-12 20:38:23 +0000
commitd7eabb20052bebd3113cd16eaec1242ca174420a (patch)
tree413c992c213e35ed5411133e70ffd657e8de05a1 /games-action
parentbumped r1 to x86, updated headers and metadata (diff)
downloadgentoo-2-d7eabb20052bebd3113cd16eaec1242ca174420a.tar.gz
gentoo-2-d7eabb20052bebd3113cd16eaec1242ca174420a.tar.bz2
gentoo-2-d7eabb20052bebd3113cd16eaec1242ca174420a.zip
glx fix #37752
Diffstat (limited to 'games-action')
-rw-r--r--games-action/glaxium/ChangeLog9
-rw-r--r--games-action/glaxium/files/0.5-another-glx.patch25
-rw-r--r--games-action/glaxium/glaxium-0.5.ebuild16
3 files changed, 39 insertions, 11 deletions
diff --git a/games-action/glaxium/ChangeLog b/games-action/glaxium/ChangeLog
index e1d8ae2c8728..401c8725865a 100644
--- a/games-action/glaxium/ChangeLog
+++ b/games-action/glaxium/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for games-action/glaxium
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.4 2003/12/16 00:16:57 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.5 2004/01/12 20:38:05 vapier Exp $
+
+*glaxium-0.5 (19 Jun 2003)
+
+ 12 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add another nvidia patch ... this time for 1.0.5328 #37752.
15 Dec 2003; Jon Portnoy <avenj@gentoo.org> glaxium-0.5.ebuild :
AMD64 keywords.
-*glaxium-0.5 (19 Jun 2003)
-
06 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
Make it work w/nvidia opengl header files #30322.
diff --git a/games-action/glaxium/files/0.5-another-glx.patch b/games-action/glaxium/files/0.5-another-glx.patch
new file mode 100644
index 000000000000..8900c1b7c891
--- /dev/null
+++ b/games-action/glaxium/files/0.5-another-glx.patch
@@ -0,0 +1,25 @@
+--- myship.cpp.orig 2004-01-12 15:22:58.893377848 -0500
++++ myship.cpp 2004-01-12 15:23:07.262105608 -0500
+@@ -39,9 +39,7 @@
+ extern PFNGLCOMBINERINPUTNVPROC glCombinerInputNV;
+ extern PFNGLCOMBINEROUTPUTNVPROC glCombinerOutputNV;
+ extern PFNGLFINALCOMBINERINPUTNVPROC glFinalCombinerInputNV;
+-#ifdef WIN32
+ extern PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
+-#endif
+ int MyShip::list_;
+
+
+--- scene.cpp.orig 2004-01-12 15:23:17.217592144 -0500
++++ scene.cpp 2004-01-12 15:23:25.009407608 -0500
+@@ -63,10 +63,8 @@
+ PFNGLTRACKMATRIXNVPROC glTrackMatrixNV;
+ PFNGLPROGRAMPARAMETER4FNVPROC glProgramParameter4fNV;
+
+-#ifdef WIN32
+ PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
+ PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
+-#endif
+
+ GLenum glError;
+
diff --git a/games-action/glaxium/glaxium-0.5.ebuild b/games-action/glaxium/glaxium-0.5.ebuild
index f04bf2fc8c5f..dee0bc7cf820 100644
--- a/games-action/glaxium/glaxium-0.5.ebuild
+++ b/games-action/glaxium/glaxium-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.3 2003/12/16 00:16:57 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.4 2004/01/12 20:38:05 vapier Exp $
inherit games flag-o-matic gcc
@@ -25,17 +25,17 @@ S=${WORKDIR}/${PN}_${PV}
src_unpack() {
unpack ${A}
cd ${S}
- ebegin "Checking if glx patch is needed"
- $(gcc-getCXX) ${FILESDIR}/glx-test.c
- local ret=$?
- [ ${ret} -eq 0 ] || epatch ${FILESDIR}/${PV}-glx.patch
- eend ${ret}
+ $(gcc-getCXX) ${FILESDIR}/glx-test.c >& /dev/null
+ if [ $? -ne 0 ] ; then
+ epatch ${FILESDIR}/${PV}-glx.patch
+ append-flags -DGL_GLEXT_LEGACY
+ fi
+ has_version '~media-video/nvidia-glx-1.0.5328' && epatch ${FILESDIR}/${PV}-another-glx.patch
}
src_compile() {
- append-flags -DGL_GLEXT_LEGACY
egamesconf --datadir=${GAMES_DATADIR_BASE} || die
- make || die
+ emake || die
}
src_install() {